Bug 169627 - Menus need a Documentation group
Menus need a Documentation group
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 08:59 EDT by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 11:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add Documentation menu to Main Menu (Applications) (669 bytes, patch)
2005-09-30 09:01 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Paul W. Frields 2005-09-30 08:59:09 EDT
Description of problem:
The redhat-menus package does not seem to allow a top-level Documentation group
in the "Applications" menu on the desktop.  The Fedora Documentation Project
plans to install our documentation in scrollkeeper for use by yelp and
khelpcenter, but unfortunately neither of those packages allows for effectively
adding a top-level group that makes our official docs apparent to the user. 
Doing so would require patching in a way that is not compatible with Fedora
strategies.

However, the menus in Red Hat Linux and Enterprise Linux used to provide such a
group, and we would like to see that return.  We are working toward a RPM
package release of some of our documentation for FC5, and it would be optimal to
have it appear where the user is likely to find and use it.  (As I mentioned, it
will also appear in the "Help" function on the Desktop menu, but we do not have
an easy way of keeping it from being buried one or more layers away from the top
of that application.)


Version-Release number of selected component (if applicable):
3.8-1

How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:
N/A

Expected results:
When the user clicks Applications, they should see a Documentation group which
gives quick access to reference material for users who are not online.

Additional info:
If there is a way to do this with a drop-in ".menu" file under /etc/xdg, any
guidance would be appreciated.  I've tried everything I could imagine might
work, without any positive results.  Obviously, we'd love to provide the menu in
our own package if possible.

I'm attaching a patch for redhat-menus in the event you have no problem with
this idea.
Comment 1 Paul W. Frields 2005-09-30 09:01:30 EDT
Created attachment 119462 [details]
Patch to add Documentation menu to Main Menu (Applications)

Whoops, somehow this didn't end up in the original entry.
Comment 2 Mark McLoughlin 2005-10-12 09:44:45 EDT
What you probably want is for the documentation RPM to install a .menu file in
/etc/xdg/menus/applications-merged ... it would look something like

<Menu>
  <Name>Documentation</Name>
  <Directory>Documentation.directory</Directory>

  <Include>
    <Category>X-Fedora-Documentation</Category>
  </Include>
</Menu>

and install a Documentation.directory in /usr/share/desktop-directories and
install a .desktop file with Category=X-Fedora-Documentation; for each doc in
/usr/share/applications
Comment 3 Paul W. Frields 2005-10-12 10:43:25 EDT
Thanks for the tip.  I did, in fact, try this before, but failed miserably. I
think it was because I had an <And> inside the <Include> that was superfluous,
but also I had a <MergeFile> in the <Menu> container as well.  Why I thought
this was necessary I don't know.  But I'll simply plead ignorance and revise our
packaging!  Thanks so much for the help!

Note You need to log in before you can comment on or make changes to this bug.