Bug 1696270 - alt+esc doesn't work anymore in 3.32
Summary: alt+esc doesn't work anymore in 3.32
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Keywords:
Depends On:
Blocks: F30FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-04-04 12:48 UTC by Milan Zink
Modified: 2019-04-21 20:32 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-21 20:32:53 UTC


Attachments (Terms of Use)

Description Milan Zink 2019-04-04 12:48:54 UTC
Description of problem:

Pressing Alt+Esc doesn't do anything after upgrading to Gnome 3.32 and it prints this error message in the systemd journal when I press it:

JS ERROR: TypeError: this._switcherList is null
vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13


Version-Release number of selected component (if applicable):
gnome-shell-3.32.0-1.fc30.x86_64

How reproducible:
Hit Alt+Esc - switch windows directly shortcut (for example)

Steps to Reproduce:
above

Actual results:
Shortcut not working
JS ERROR: TypeError: this._switcherList is null

Expected results:
Working shortcut


Additional info:
Seems to be fixed upstream - https://gitlab.gnome.org/GNOME/gnome-shell/issues/1064 -- needs never gnome-shell package

Comment 1 American Dave 2019-04-07 17:45:54 UTC
I'm also affected, and I see the following when running "journalctl -lab --follow" and attempting to switch:

Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._settings is undefined
                                       _getWindows@resource:///org/gnome/shell/ui/altTab.js:630:1
                                       _init@resource:///org/gnome/shell/ui/altTab.js:485:23
                                       _init@resource:///org/gnome/shell/ui/altTab.js:622:9
                                       _startSwitcher@resource:///org/gnome/shell/ui/windowManager.js:2075:24
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13
Apr 07 12:43:48 xps gnome-shell[1858]: JS ERROR: TypeError: this._switcherList is null
                                       vfunc_allocate@resource:///org/gnome/shell/ui/switcherPopup.js:81:13

Comment 2 Fedora Blocker Bugs Application 2019-04-17 09:35:21 UTC
Proposed as a Blocker for 30-final by Fedora user mzink using the blocker tracking app because:

 final - Default shortcut is not working. Affects general desktop user experience.

Comment 3 Adam Williamson 2019-04-17 15:03:18 UTC
Not sure this is a blocker, but +1 FE at least, be nice to fix this in lives for people who use it.

Comment 4 Fedora Update System 2019-04-17 16:09:42 UTC
gnome-shell-3.32.0-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 5 Milan Zink 2019-04-18 06:33:09 UTC
gnome-shell-3.32.0-3.fc30 is fixing this issue. Thank you.

3.32.1 - https://koji.fedoraproject.org/koji/buildinfo?buildID=1252212 is also working fine.

Comment 6 Fedora Update System 2019-04-18 18:24:32 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 7 Michael Catanzaro 2019-04-18 18:59:33 UTC
(In reply to Adam Williamson from comment #3)
> Not sure this is a blocker, but +1 FE at least, be nice to fix this in lives
> for people who use it.

Agreed: -1 blocker, +1 FE

Comment 8 Michael Catanzaro 2019-04-18 19:00:09 UTC
There was no proposed blocker criterion anyway, and it would be a stretch to apply any of them to this.

Comment 9 Julen Landa Alustiza 2019-04-18 19:24:44 UTC
-1 blocker +1 fe

Comment 10 Zbigniew Jędrzejewski-Szmek 2019-04-19 08:19:03 UTC
-1 blocker, +1 fe

Comment 11 Adam Williamson 2019-04-19 15:21:44 UTC
That's enough votes to reject as blocker but accept as FE.

Comment 12 Fedora Update System 2019-04-21 20:32:53 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.