Bug 1696299 - installing appcenter breaks dbus-broker
Summary: installing appcenter breaks dbus-broker
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus-broker
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Gundersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F30FinalBlocker 1649555
TreeView+ depends on / blocked
 
Reported: 2019-04-04 13:20 UTC by Fabio Valentini
Modified: 2019-04-14 00:01 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-06 17:37:24 UTC


Attachments (Terms of Use)

Description Fabio Valentini 2019-04-04 13:20:27 UTC
Description of problem:

After installing the pantheon-session-settings package on fedora 30, gdm won't come up at boot at all. The log files for that boot don't show anything of interest, but I have to force reset the machine, boot into multi-user.target, and dnf remove pantheon-session-settings - only then gdm works again at the next boot.


Version-Release number of selected component (if applicable):
gdm-3.32.0-1.fc30.x86_64
pantheon-session-settings-29.90-1.fc30.noarch


How reproducible:
100% reliable, both on clean installs of f30 beta and when upgraded from f29


Steps to Reproduce:
1. Start with either a clean install of f30 beta or upgrade from f29
2. install pantheon-session-settings / group "Pantheon Desktop"
3. reboot
4. GDM won't start


Actual results:
gdm is broken.


Expected results:
gdm works and shows the "Pantheon" session.

Comment 1 Fedora Blocker Bugs Application 2019-04-06 13:46:36 UTC
Proposed as a Blocker for 30-final by Fedora user decathorpe using the blocker tracking app because:

 Installing either the "pantheon-session-settings" package or the "Pantheon Desktop" group (which contains the package) completely breaks the system - gdm won't start successfully at the next boot.

However, it still seems to capture Ctrl-Alt-FX keys, so the only way to fix it again is to *boot into multi-user.target* and "dnf remove" the packages again.

I don't think it's acceptable that installing packages can effectively lock users out of their system for good if they don't know how to set "systemd.unit=multi-user.target" on the kernel command line ...

Comment 2 Adam Williamson 2019-04-06 15:33:52 UTC
ctrl-alt-f3 doesn't get you to a console?

Comment 3 Adam Williamson 2019-04-06 15:35:31 UTC
also, why assign this to gdm when it seems a lot more like a pantheon bug?

Comment 4 Fabio Valentini 2019-04-06 15:46:06 UTC
No, Ctrl-Alt-F1-12 don't do anything.

And ... why would this be a Pantheon bug? I can't even get to the GDM login screen.

Comment 5 Adam Williamson 2019-04-06 15:49:53 UTC
because GDM works fine until you install Pantheon, implying Pantheon does something to break GDM...that's how it seems to me, anyway.

Comment 6 Fabio Valentini 2019-04-06 16:03:57 UTC
The only thing that should change for GDM is an additional file in "/usr/share/gnome-session/sessions".
All autostart entries for Pantheon are qualified with "OnlyShowIn=Pantheon;".

There's basically no difference between the Pantheon session files for fedora 29 and 30.

Everything works fine on fedora 29.
After upgrading to fedora 30, GDM fails to start.

So .. I have no idea what's going wrong here.

Comment 7 Fabio Valentini 2019-04-06 16:15:38 UTC
Additional info: Installing the "pantheon-sesion-settings" package that works fine on fedora 29 doesn't change anything.

So the only moving part here really is GDM, AFAICT.

Comment 8 Fabio Valentini 2019-04-06 16:59:45 UTC
Crawling through the logs almost line by line, I think I found the real issue here:

dbus-broker.service: Main process exited, code=exited, status=1/FAILURE

Which is preceded by this crash in dbus-broker-launch:

ERROR manager_add_services @ ../src/launch/main.c +1130: Input/output error
      manager_run @ ../src/launch/main.c +1708
      run @ ../src/launch/main.c +1857
      main @ ../src/launch/main.c +1886
Exiting due to fatal error: -5


Which isn't even caused by anything in pantheon-session-settings -
but by the appcenter dbus service (for a reason I cannot imagine).


So, sorry about blaming GDM for this, it's dbus-broker that crashes and brings down GDM with it.

Comment 9 Fabio Valentini 2019-04-06 17:37:24 UTC
I've decided to retire the broken package (appcenter) instead of spending even more time on this. It's not worth it.

Thanks everybody for your help, and sorry for any trouble I might have caused you.

Comment 10 David Rheinsberg 2019-04-09 07:07:29 UTC
Right, I looked at Elementary-AppCenter and it installs a dbus-service-file with `Name=AppCenter`. This is not a valid dbus-service-name. I don't know how this ever worked on dbus-daemon, but dbus-broker refuses this and will complain when you provide invalid configuration data. I assume the service file was simply ignored but dbus-daemon.

Anyway, I will look into improving the error-message from dbus-broker there! Thanks for the report!

Comment 11 Fabio Valentini 2019-04-09 07:19:19 UTC
Well, it's definitely not urgent anymore, since I removed the package from fedora (it had numerous other issues, as well).

But I will provide this information to the upstream elementary / appcenter developers. Thank you!

Comment 12 David Rheinsberg 2019-04-09 12:40:42 UTC
For completeness: This is now fixed in upstream dbus-broker. It will be included in the v20 release this week. The fix now makes dbus-broker ignore service files with invalid names.

Comment 13 Fabio Valentini 2019-04-09 13:32:41 UTC
Great, thanks! That should make it more robust for everybody. :)

Comment 14 Fedora Update System 2019-04-11 11:15:16 UTC
dbus-broker-20-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c1189aa7ea

Comment 15 Fedora Update System 2019-04-13 01:58:01 UTC
dbus-broker-20-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c1189aa7ea

Comment 16 Fedora Update System 2019-04-14 00:01:54 UTC
dbus-broker-20-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.