Bug 1696342 - [UPI] openshift-install upi finish fails searching for a file which is not found
Summary: [UPI] openshift-install upi finish fails searching for a file which is not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 15:04 UTC by David Sanz
Modified: 2019-06-04 10:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:11 UTC

Description David Sanz 2019-04-04 15:04:58 UTC
Description of problem:
Final step on a UPI installation is to execute "openshift-install upi finish" and wait until it ends.

It finish when find a stable version on "oc clusterversion" but tries to search for a file, and this file is not found:

[root@dell-r730-069 baremetal-0404]# /root/bin/openshift-install-4.0.0-0.nightly-2019-04-04-030930 --dir /root/installation/baremetal-0404 upi finish
INFO Waiting up to 30m0s for the cluster at https://api.morenod-baremetal.ogtlabs.es:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
FATAL open /root/installation/baremetal-0404/auth/kubeadmin-password: no such file or directory 

[root@dell-r730-069 baremetal-0404]# pwd
/root/installation/baremetal-0404
[root@dell-r730-069 baremetal-0404]# ls
auth  bootstrap.ign  master.ign  metadata.json  worker.ign
[root@dell-r730-069 baremetal-0404]# ls -l auth/
total 16
-rw-r--r--. 1 root root 13436 abr  4 09:47 kubeconfig
[root@dell-r730-069 baremetal-0404]# 



Version-Release number of the following components:
# /root/bin/openshift-install-4.0.0-0.nightly-2019-04-04-030930 --dir /root/installation/baremetal-0404 version
/root/bin/openshift-install-4.0.0-0.nightly-2019-04-04-030930 v4.0.22-201904032147-dirty
built from commit b6625b4084fb01ffbe190f1c74208ea00b4b7d9b
release image registry.svc.ci.openshift.org/openshift/origin-release:v4.0


How reproducible:

Steps to Reproduce:
1.Install baremetal cluster following the UPI guide
2.Execute openshft-install upi finish and wait until cluster is correctly installed

Actual results:
Command fails trying to access a file not generated

Expected results:
Command ends ans shows the file.

Additional info:

Comment 1 Johnny Liu 2019-04-09 08:05:36 UTC
The same issue also reproduced in upi-on-aws install.

# ./openshift-install user-provided-infrastructure finish --dir upi_2019-04-07-22-52-02/
INFO Waiting up to 30m0s for the cluster at https://api.jialiuuuu1.qe1.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
FATAL open /root/ocp-4.0/20190408/upi_2019-04-07-22-52-02/auth/kubeadmin-password: no such file or directory 

payload version:
registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-04-05-165550

Comment 2 Abhinav Dahiya 2019-04-10 22:15:29 UTC
https://github.com/openshift/installer/pull/1592

Comment 4 Gaoyun Pei 2019-04-12 07:39:25 UTC
The same issue in upi-on-vsphere with payload registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-04-10-182914 

# ./openshift-install wait-for cluster-ready
INFO Waiting up to 30m0s for the cluster at https://api.gpei-vsp-0412.qe.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
FATAL open /root/vmware_launcher/0412/vsphere/auth/kubeadmin-password: no such file or directory

Comment 5 David Sanz 2019-04-12 09:15:02 UTC
Using 4.1.0-0.nightly-2019-04-12-071533 for baremetal upi

File is present:

# ls
auth  bootstrap.ign  master.ign  metadata.json  worker.ign
# ls -l auth/
total 16
-rw-r--r--. 1 root root    23 abr 12 04:38 kubeadmin-password
-rw-r--r--. 1 root root 10476 abr 12 04:38 kubeconfig
# cat auth/kubeadmin-password 
VyK************X-SMRbg

Comment 6 David Sanz 2019-04-16 15:46:31 UTC
Verified on unreleased-master-811-g5a3c57cb37b0f175c2ae33e64cd9a6947bd1d567-dirty

Comment 7 Johnny Liu 2019-04-19 09:10:51 UTC
Verified this bug with 4.1.0-0.nightly-2019-04-18-210657, and PASS.

# ./openshift-install version
./openshift-install v4.1.0-201904181302-dirty
built from commit b79562d600f72d0f70aa1514b01e6c07da4dcc8a
release image registry.svc.ci.openshift.org/ocp/release:4.1.0-0.nightly-2019-04-18-210657


# ./openshift-install wait-for install-complete --dir ./upi_2019-04-19-03-38-01
INFO Waiting up to 30m0s for the cluster at https://api.jialiu-upi1.qe1.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
INFO Install complete!                            
INFO To access the cluster as the system:admin user when using 'oc', run 'export KUBECONFIG=/root/ocp-4.0/20190419/upi_2019-04-19-03-38-01/auth/kubeconfig' 
INFO Access the OpenShift web-console here: https://console-openshift-console.apps.jialiu-upi1.qe1.devcluster.openshift.com 
INFO Login to the console with user: kubeadmin, password: hgd37-UfgGt-LZ4Lj-w28cK 


# tree upi_2019-04-19-03-38-01/
upi_2019-04-19-03-38-01/
├── auth
│   ├── kubeadmin-password
│   └── kubeconfig
├── bootstrap.ign
├── master.ign
├── metadata.json
└── worker.ign

1 directory, 6 files

Comment 8 Gaoyun Pei 2019-04-23 05:21:14 UTC
Works well for upi-on-vsphere with 4.1.0-0.nightly-2019-04-22-005054

# ./openshift-install version
./openshift-install v4.1.0-201904211700-dirty
built from commit f3b726cc151f5a3d66bc7e23e81b3013f1347a7e
release image registry.svc.ci.openshift.org/ocp/release@sha256:3f3628cd9b694705cb0627ce72e61932df5d9938a291fabba1ed691230f7b548


# ./openshift-install wait-for install-complete
INFO Waiting up to 30m0s for the cluster at https://api.gpei-0423.qe.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
INFO Install complete!                            
INFO To access the cluster as the system:admin user when using 'oc', run 'export KUBECONFIG=/root/vmware_launcher/0423/vsphere/auth/kubeconfig' 
INFO Access the OpenShift web-console here: https://console-openshift-console.apps.gpei-0423.qe.devcluster.openshift.com 
INFO Login to the console with user: kubeadmin, password: JhMCs-BDzhV-Bhikj-Uthy3 

# cat auth/kubeadmin-password 
JhMCs-BDzhV-Bhikj-Uthy3

Comment 10 errata-xmlrpc 2019-06-04 10:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.