Bug 169637 - X fails to start with recent kernels on bootup
X fails to start with recent kernels on bootup
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-09-30 10:59 EDT by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-20 04:30:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
This is the current xorg.conf file using the vesa driver (was radeon) (3.99 KB, text/plain)
2005-10-01 05:56 EDT, Mike Cohler
no flags Details
xorg log with the radeon driver for the kernel which DOES work (1398) (51.96 KB, text/plain)
2005-10-01 05:59 EDT, Mike Cohler
no flags Details
xorg log from boot with radeon driver which hangs X with new kernel (51.60 KB, text/plain)
2005-10-01 12:16 EDT, Mike Cohler
no flags Details
xorg.conf after executing your suggestions above (2.80 KB, text/plain)
2005-10-03 05:01 EDT, Mike Cohler
no flags Details
Xorg.0.log current (51.14 KB, text/plain)
2005-10-03 05:02 EDT, Mike Cohler
no flags Details
Ouput from lsmod command (2.30 KB, text/plain)
2005-10-03 05:04 EDT, Mike Cohler
no flags Details
Current xorg.conf that leads to successful boot with latest kernel (2.77 KB, text/plain)
2005-10-04 07:54 EDT, Mike Cohler
no flags Details
Xorg.0.log for successful boot with radeon driver latest kernel, NO dri (48.14 KB, text/plain)
2005-10-04 07:56 EDT, Mike Cohler
no flags Details
/var/log/messages after successful boot (146.57 KB, text/plain)
2005-10-04 07:58 EDT, Mike Cohler
no flags Details
My modded /etc/X11/prefdm (1.25 KB, text/plain)
2006-01-28 16:01 EST, Bob Maynard
no flags Details

  None (edit)
Description Mike Cohler 2005-09-30 10:59:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
For all new kernels released for FC4 after kernel-2.6.12-1.1398_FC4 X freezes on bootup after the main boot sequence just as X starts. At this point the keyboard and mouse are locked, and it is impossible to regain control without re-booting the machine.
Once the system is frozen it is impossible to switch to alternative consoles using ctrl-alt-Fn.

My graphics card is PCI:

00:08.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] (prog-if 00 [VGA])
        Subsystem: PC Partner Limited: Unknown device 0020
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 10
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at e800 [size=256]
        Memory at e0020000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at 0f900000 [disabled] [size=128K]

However there is also an onboard graphics which I do not use (and which cannot be removed):
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (prog-if 00 [VGA])
        Subsystem: Trident Microsystems CyberBlade/i1
        Flags: 66Mhz, medium devsel, IRQ 10
        Memory at dd800000 (32-bit, non-prefetchable) [disabled] [size=8M]
        Memory at de000000 (32-bit, non-prefetchable) [disabled] [size=128K]
        Memory at dd000000 (32-bit, non-prefetchable) [disabled] [size=8M]
        [virtual] Expansion ROM at 0f800000 [disabled] [size=64K]

All of the following kernels are affected:

My system is running an Athlon processor i386 with FC4 running and fully up to date as of 30th September 2005.

At this point I was using the "radeon" driver in xorg.conf

However if I switch to the "vesa" driver in xorg.conf the system successfully boots up with all the affected kernels, though with some odd graphics appearing on the way to the login screen (I am using KDE as the desktop with the KDM login screen)

This would point to an xorg problem rather than a kernel problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Reboot
2. The sysem begins booting
3. X fails to start and the system hangs

Actual Results:  The screen is black and the mouse and keyboard frozen out.

Expected Results:  The system should boot and X should start and give the normal login screen.

Additional info:
Comment 1 Alexei Podtelezhnikov 2005-09-30 13:55:10 EDT
Please attach (via link below) /var/log/Xorg.0.log, which contains the details  
of the failure. You may need remote login to get this. Also, attach working 
Xorg.0.log with the old kernel for comparison purposes. Also, your xorg.conf 
is needed. 
Comment 2 Mike Cohler 2005-10-01 05:56:25 EDT
Created attachment 119500 [details]
This is the current xorg.conf file using the vesa driver (was radeon)

The version which casued the problem with the newer kernels only has "radeon"
replacing "vesa" as the only change
Comment 3 Mike Cohler 2005-10-01 05:59:35 EDT
Created attachment 119501 [details]
xorg log with the radeon driver for the kernel which DOES work (1398)

This log corresponds to the last kernel which does give a successful boot with
X running correctly using the radeon driver.

I will have to wait until Monday to revert the computer to the radeon driver
and do a failed boot with on of the more recent kernels. I will send that
attachment on Monday 3rd October.

Comment 4 Mike Cohler 2005-10-01 12:16:56 EDT
Created attachment 119507 [details]
xorg log from boot with radeon driver which hangs X with new kernel

This xorg log was obtained when booting using the latest FC4 kernel and the
system freezes just as X starts after the main boot sequence. The log was
obtained by logging in remotely whilst the screen was black, and the mouse and
keyboard locked up.
Comment 5 Mike A. Harris 2005-10-03 02:57:39 EDT
Run "yum update" to install all of the latest FC4 updates.  After it's done,
run "system-config-display --reconfig" then do not edit the xorg.conf at all.

Reboot the system to ensure full hardware reset, and let it come back up into
X after reboot.

Attach the X server config file and log file from after this.  Also include
the output of "lsmod".

Comment 7 Mike Cohler 2005-10-03 04:58:16 EDT
OK I have done what you suggested - the system was in fact already fully up to
date (nightly) but I have run yum update again today and no further updates came in.

In order to start with a fully up to date system I booted with the "vesa" driver
and with the latest kernel (2.6.13-1.1526_FC4). 

Then ran system-config-display --reconfig as you suggested. I then selected "ATI
radeon VE" as the graphics. Then shutdown to power off, and started up from
scratch booting kernel 2.6.13-1.1526_FC4.

The system has now booted normally and X loaded without problems (although with
USA rather than UK keyboard, which I have reset from K->System Settings->
Keyboard) before attaching the requested files which follow.

Comment 8 Mike Cohler 2005-10-03 05:01:02 EDT
Created attachment 119538 [details]
xorg.conf after executing your suggestions above

xorg.conf after doing your suggestions today (and after resetting the keyboard
from K->System Settings-> Keyboard
Comment 9 Mike Cohler 2005-10-03 05:02:54 EDT
Created attachment 119539 [details]
Xorg.0.log current 

This is for the system now booted successfully with kernel 2.6.13-1.1526_FC4
and ATI radeon VE driver
Comment 10 Mike Cohler 2005-10-03 05:04:23 EDT
Created attachment 119540 [details]
Ouput from lsmod command

lsmod output after the booting as suggested.
Comment 11 Mike Cohler 2005-10-03 05:07:19 EDT

Thank you for sorting this out.  Others who are running the same graphics card
will certainly want to see this ahead of any fix upstream, and I hope that these
files will provide sufficient diagnostics for a fix to be possible via normal

I am now golden again...

Best wishes

Comment 12 Mike Cohler 2005-10-03 05:22:58 EDT
I spoke too soon !

After the above and without any further changes I decided to check that all was
well by re-booting.

I am now back to square 1  - i.e. it fails to load X with the latest kernel but
reverting back to 2.6.12-1.1398 boots and loads X without problems.

There is clearly a residual problem.

Comment 13 Mike A. Harris 2005-10-03 09:41:16 EDT
It appears that DRI is still being enabled even though it should disable
itself on this card.  It's possible the dri-disable patch might not
be working properly.  Please manually disable DRI, by commenting out
the following line in your config file:

    Load "dri"

Then reboot and restart the X server, and attach the new config and
log file.  ALso attach /var/log/messages from both with and without
DRI, and indicate which is which.

Comment 14 Mike Cohler 2005-10-04 07:52:00 EDT

I had a problem yesterday trying to recover from one of the failed re-boots
which resulted in a file system journal error, and this then excalated into a
problem being unable to boot at all. To cut a long story short it was necessary
to do a complete re-install of FC4 !  However this has lost me a day of work,
but I am now  back in action with a fresh install, and fully up to date.

After all the yum updates were in, I changed xorg.conf to comment out the
loading of DRI, and switched the graphics driver to radeon, then booted to the
latest kernel.

The boot process was fine and X started just fine. The system seems to be
running flawlessly now. So this certainly looks like the DRI loading was the
cause of the problem, but I am not going to try to reboot with "load "DRI" " in
xorg.conf since I now have to catch up on my lost time from yesterday. I will
attach the xorg.conf, messages and xorg log files shortly.

Comment 15 Mike Cohler 2005-10-04 07:54:00 EDT
Created attachment 119584 [details]
Current xorg.conf that leads to successful boot with latest kernel

Successful boot for radeon driver, NO dri, kernel 2.6.13-1.1526 with this
xorg.conf file.
Comment 16 Mike Cohler 2005-10-04 07:56:18 EDT
Created attachment 119585 [details]
Xorg.0.log for successful boot with radeon driver latest kernel, NO dri

xorg log file for successful boot with kernel 2.6.13-1.1526, radeon graphics
driver, NO dri after complete fresh install of the operating system yesterday.
Comment 17 Mike Cohler 2005-10-04 07:58:39 EDT
Created attachment 119586 [details]
/var/log/messages after successful boot

/var/log/messages file after successful boot following complete re-install of
the operating system and fully up to date. Using kernel 2.6.13-1.1526, radeon
graphics driver and NO "dri" loaded via xorg.conf
Comment 18 Ed Holden 2005-11-08 16:44:58 EST
In case it matters at this point, I had an identical problem to this.  Like the
submitter of this bug, I found that my ATI (same card) configuration caused the
machine to pull a black-screen when starting X.  The original FC4 Xorg build
worked fine, but the upgrade clearly broke something.  I also had filesystem
corruption and had to reinstall FC4.

The above DRI-less configuration fixed the problem for me completely as well.
Comment 19 Bob Maynard 2006-01-28 15:59:15 EST
Workaround Hack:
Had same probles with Radeon 7000 and 9200Pro.  Sometimes lockup on start of
gdm, sometimes no switch to text mode, sometimes text mode corrupt. Disable DRI
worked mostly, but graphics performance in the toilet.  Workaround:
edit /etc/X11/prefdm and a) ping rhgb and if true chvt 1 and echo any text to
vt1 b) then kill rhgb
else echo any old text.

This gets text into a free vt before starting the gdm or graphics switchover.

Comment 20 Bob Maynard 2006-01-28 16:01:38 EST
Created attachment 123842 [details]
My modded /etc/X11/prefdm
Comment 21 Mike Cohler 2006-04-21 15:53:56 EDT
This problem seems to have recurred for FC5.  I today installed FC5 (clean
install) on the same system.  The initial install refused to allow me to get a
graphical install, and I opted to try a text install - this worked apparently
fine. However once the install was complete the system refused to go into first
boot, with the machine hanging as soon as it tried to start X.

This is much more severe than the reports above, in that I cannot get the system
to boot at all, even into level 3 my any apparent adjustment of the grub boot lines.

I can however boot into linux rescue from the CD1 - but changing the xorg.conf
to have the vesa driver instead of the trident which was detected by default,
also fails to start X and the same if I try the radeon driver.

I cannot get to the machine again until next week so cannot run tests this
weekend - but at present it is impossible to make any headway.

I have tried running yum update to get the new kernel in rescue mode, which
works but makes no difference. I have also tried updating xorg-X11-server which
also makes no difference.

I have to admit I have not done a full yum update at this stage and will try
that next week - however today I did try system-config-display --reconfig under
rescue mode but that failed to complete.

If there are any suggestions between now and early next week I would very much
appreciate it.

Comment 22 Christian Iseli 2007-01-19 19:16:26 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 23 Mike Cohler 2007-01-20 04:30:10 EST
I no longer have access to the hardware to test this so I will close this bz.

Note You need to log in before you can comment on or make changes to this bug.