Bug 169677 - Deselecting any package disables FORWARD button
Deselecting any package disables FORWARD button
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: 191074 191079
  Show dependency treegraph
 
Reported: 2005-09-30 18:42 EDT by Ian Laurie
Modified: 2013-01-10 03:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.4.67-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 13:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2005-09-30 18:42:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.7.12-1.1.3.2

Description of problem:
After 'checking/clicking' the 'select all packages' checkbox, deselecting any package disables the FORWARD button, requiring you to deselect and then reselect some other package, as selecting a package re-enables the button.

As I am running a latter version of spamassassin than the one in the channel, I must always deselect it after clicking on the 'select all packages' check-box.  This disables the forward button.  Previous version did not do this.


Version-Release number of selected component (if applicable):
up2date-4.4.44-3

How reproducible:
Always

Steps to Reproduce:
1. Launch up2date.
2. Click 'select all packages' or whatever its called.
3. Deselect something on the list.
4. Observer that the button is disabled even though there may be 100 other packages to get.
  

Actual Results:  Button disabled.

Expected Results:  Button should be enabled if there are packages in the list to fetch.

Additional info:

Previous version was OK.
Comment 1 don 2006-02-12 22:05:29 EST
I think this was added in FC4, because FC3 or FC2 didn't do this. Some
programmer probabaly thought it would be clever to have the forward button
disabled if "all" the packages are supposed to be installed but one of them is
unchecked. . . Except this is very annoying, because the only way it got
unchecked is the user unchecked it. And the only other way to check the 99 other
packages is one at a time. Please turn this into a real "Select All"/"Unselect
All" button, or at least restore old behavior.
Comment 2 Ian Laurie 2006-03-20 02:08:57 EST
This seems to be fixed by an update through the channel, version up2date-4.4.67-3.
Comment 4 Fanny Augustin 2006-04-10 20:39:45 EDT
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release
Comment 5 Fanny Augustin 2006-04-13 15:49:25 EDT
Moving bugs to the CanFix List
Comment 6 Ian Laurie 2006-04-19 01:38:55 EDT
Current version up2date-4.4.67-3 does not suffer from this problem.

Should be marked are ERRATA?
Comment 7 James Bowes 2006-05-02 13:52:58 EDT
This is fixed in at least release 4.4.67-4
Comment 8 Fanny Augustin 2006-05-08 15:30:11 EDT
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release
Comment 9 Fanny Augustin 2006-05-08 16:09:24 EDT
This bug did not make the code freeze.  It will not be fixed in this releasee 
Reea ligning to the next one.

Note You need to log in before you can comment on or make changes to this bug.