Bug 169683 - toolbar application cannot be started
Summary: toolbar application cannot be started
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
(Show other bugs)
Version: 4
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-01 02:02 UTC by Roman Ekjanov
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 23:20:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My rpms (57.40 KB, text/plain)
2005-11-25 02:10 UTC, Roman Ekjanov
no flags Details

Description Roman Ekjanov 2005-10-01 02:02:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
toolbar application cannot be started because it requires another erlang application - gs, which is not built. gs uses tcl, and it looks like that build environment doesn't have tcl-devel installed.


Version-Release number of selected component (if applicable):
erlang-R10B-6.3

How reproducible:
Always

Steps to Reproduce:
1. start erlang shell (erl)
2.try to start toolbar application - toolbar:start().

  

Actual Results:  error description displayed

Expected Results:  New toolbar window with buttons should pop up.

Additional info:

Comment 1 Gérard Milmeister 2005-10-01 09:20:44 UTC
Thanks.
A new build is in the making.
Close this bug if it works as expected.

Comment 2 Scott Ross 2005-10-29 17:27:33 UTC
The erlang-R10B-6.4 i386 version (downloaded Oct 5) also seems to have a similar
problem. It is missing the compiled versions of gs, gstk and various source
(.erl) files.  It is also missing the java_src for the idl compiler (ic), the
java source for jinterface, a couple of files from the orber (examples for java
access) and several files from the ssl-3.0.7 library.  It looks like the compile
failed because there is a crash.dump file which got included in the binary.rpm.
    /usr/lib/erlang/releases/R10B/erl_crash.dump
The date on this file is Oct 1 at 3:37.

If I compile from the source rpm it seems to compile ok, gs seems to work fine
(limited testing, but at least windows popup).

Comment 3 Gérard Milmeister 2005-10-29 19:54:33 UTC
Currently the package is broken (probably due to a change
to the build requirement packages).

I will soon request a build for the new version R10B-8 and
then post the results.

Comment 4 Gérard Milmeister 2005-11-01 21:11:51 UTC
I enabled building using java, but unfortunately this created havoc
on the build system. Building locally in mock creates a working
package however. At least "toolbar:start()." works as expected and
there is not erl_crash.dump. Two jar files are created:
/usr/lib/erlang/lib/ic-4.2.9/priv/ic.jar
/usr/lib/erlang/lib/jinterface-1.3/priv/OtpErlang.jar
It would be useful if you checked out from CVS and tried
a build yourself.
However at the moment no java-enabled build can be requested.

Comment 5 Roman Ekjanov 2005-11-25 02:10:50 UTC
Created attachment 121471 [details]
My rpms

erlang itself was not installed at the time of the build.

Comment 6 Roman Ekjanov 2005-11-25 02:21:49 UTC
I returned to this after I upgraded my computer to fedora development.
erlang-R10B-8.3.x86_64.rpm from the development repo still has the same problem
- gs was not built. I re-built rpm from the source rpm and it came out allright.
I attached list of rpms I had installed at the time of the build (My rpms). It
is almost exclusively fedora-development system with one notable exclusion -
kernel is from fedora 4.


Comment 7 Gérard Milmeister 2006-03-13 23:20:08 UTC
Seems to work with current release.


Note You need to log in before you can comment on or make changes to this bug.