This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 169686 - AC97 related kernel oops
AC97 related kernel oops
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-09-30 23:45 EDT by Øyvind Stegard
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 01:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (15.05 KB, text/plain)
2005-09-30 23:46 EDT, Øyvind Stegard
no flags Details
lspci -vv output (8.40 KB, text/plain)
2005-09-30 23:47 EDT, Øyvind Stegard
no flags Details

  None (edit)
Description Øyvind Stegard 2005-09-30 23:45:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Got an AC97-related oops:
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:05.0 into 4x mode
Unable to handle kernel NULL pointer dereference at virtual address 000001a4
 printing eip:
df969005
*pde = 12620067
Oops: 0000 [#1]
Modules linked in: nfs radeon drm nfsd exportfs lockd nfs_acl autofs4 sunrpc pcmcia dm_mod video button battery ac yenta_socket rsrc_nonstatic pcmcia_core ohci_hcd shpchp i2c_ali1535 i2c_core snd_ali5451 snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc prism54 8139cp mii floppy joydev ext3 jbd
CPU:    0
EIP:    0060:[<df969005>]    Not tainted VLI
EFLAGS: 00010202   (2.6.13-1.1526_FC4)
EIP is at snd_ac97_valid_reg+0x5/0x135 [snd_ac97_codec]
eax: 00000000   ebx: 00000040   ecx: 00000000   edx: 00000040
esi: 00000000   edi: 00000040   ebp: 00001f40   esp: ca515edc
ds: 007b   es: 007b   ss: 0068
Process gstreamer-prope (pid: 10503, threadinfo=ca515000 task=da809aa0)
Stack: 00000040 df969149 de2ac800 00000001 d4fb1000 de3bf560 df9207ca 00000000
       fffffff4 de3bf560 db6b9000 df92d6b2 00000000 00000001 00000246 00000000
       00000000 00000000 0000025c 0000025c d4fb1000 d4fb1000 fffffff4 de3bf560
Call Trace:
 [<df969149>] snd_ac97_write+0x14/0x5a [snd_ac97_codec]
 [<df9207ca>] snd_ali_modem_hw_params+0x2c/0x4c [snd_ali5451]
 [<df92d6b2>] snd_pcm_hw_params+0x290/0x609 [snd_pcm]
 [<df92da7b>] snd_pcm_hw_params_user+0x50/0x6a [snd_pcm]
 [<df9349b5>] snd_pcm_capture_ioctl1+0x2e/0x1ce [snd_pcm]
 [<df934b70>] snd_pcm_capture_ioctl+0x0/0x1b [snd_pcm]
 [<c01bf0e9>] do_ioctl+0x19/0x55
 [<c01bf217>] vfs_ioctl+0x50/0x1aa
 [<c01bf3ce>] sys_ioctl+0x5d/0x6b
 [<c0104409>] sysenter_past_esp+0x56/0x79
Code:  Bad EIP value.
 <6>agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:05.0 into 4x mode
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode


Version-Release number of selected component (if applicable):
2.6.13-1.1526_FC4

How reproducible:
Didn't try

Steps to Reproduce:
1. I was fiddling around with gstreamer-properties (alsasink/alsasrc) at the time.


Actual Results:  Oops.

Expected Results:  No oops.

Additional info:

Attaching `lspci -vv' and complete dmesg.
Comment 1 Øyvind Stegard 2005-09-30 23:46:52 EDT
Created attachment 119497 [details]
dmesg output
Comment 2 Øyvind Stegard 2005-09-30 23:47:33 EDT
Created attachment 119498 [details]
lspci -vv output
Comment 3 Dave Jones 2005-11-10 16:56:46 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 4 Øyvind Stegard 2005-11-11 10:18:55 EST
Sorry, the hardware where this occured is no longer available to me; I've bought
a new laptop. Because of this, I will not be able to test if this bug has been
fixed in recent kernel updates.

Note You need to log in before you can comment on or make changes to this bug.