Bug 169691 - kernel-2.6.13-1.1526_FC4 panic on boot !
kernel-2.6.13-1.1526_FC4 panic on boot !
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 05:11 EDT by Daniel Roche
Modified: 2013-07-02 22:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-05 03:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Roche 2005-10-01 05:11:19 EDT
Description of problem:

just updated kernel-2.6.13-1.1526_FC4 does not boot on my laptop
( dell inspiron 9300 ).
booting the same system with kernel-2.6.12-1.1456_FC4 works well
 
Version-Release number of selected component (if applicable):

kernel-2.6.13-1.1526_FC4

How reproducible:

always !
Steps to Reproduce:
1. power on laptop
2. boot begin
3. crash
  
Actual results:

the system crash with the following messages :

mount: error 6 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup'ing fd of 0 to 0
error dup'ing fd of 0 to 1
error dup'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init !

Expected results:

booting normally

Additional info:

removing the quiet option on grub command line parameters give a lot of 
message with the following that seems important for me :

ata: 0x1F0 IDE port busy
ata: 0x170 IDE port busy
ata_piix: prone of 0000.00:1F.2 failed with error - 16

looks like a libata/ata_piix problem, the dell inspiron 9300 use this driver
for the disk

i have another FC4 system ( a PIII desktop system ) which does not reproduce
the problem !

i am currently recompiling my own kernel, i'll let you know.

Best Regards
Comment 1 Daniel Roche 2005-10-01 06:40:40 EDT
Some more precisions :

I have recompiled my own kernel, and now it works !

i downloaded kernel-2.6.13-1.1526_FC4.src.rpm, made a rpmbuild -bp
and recompiled the result after changing some options :

- select Pentium M processor ( CONFIG_MPENTIUMM=y )
- add NTFS filesystem ( CONFIG_NTFS_FS=m ) 
- set CONFIG_IKCONFIG=y and CONFIG_IKCONFIG_PROC=y
- set CONFIG_CODA_FS_OLD_API ( i need this for davfs2 !, thank you to add
            now CODA by default ! ) 
i do not think the above is important, but the following yes !
- set the IDE subsystem as module ( CONFIG_IDE=m, CONFIG_BLK_DEV_IDE=m )
- modified libata.h ( #define ATA_ENABLE_ATAPI and #define ATA_ENABLE_PATA )

recompiled , and it works !

i allways make the ide and libata modification for each new kernel on my 
inspiron 9300, if not, the dvd does not work with dma, it's painfully slow !

Best Regards !

Comment 2 Gael Fraiteur 2005-10-01 17:17:49 EDT
I had a similar problem with sata_via and a boot raid1 partition. I cannot 
confirm the workaround, since I chose to stay at 2.6.13.
Comment 3 Dave Jones 2005-10-02 17:06:35 EDT
please capture the messages before the line..

mount: error 6 mounting ext3
Comment 4 Dave Jones 2005-10-03 18:25:34 EDT
does booting with the parameter hda=noprobe  fix this ?

Comment 5 Daniel Roche 2005-10-04 02:52:03 EDT
the complete message before the crash is :

Booting 'Fedora Core (2.6.13-1.1526_FC4)'

root (hd0,1)
 Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.13-1.1526_FC4 ro root=/dev/sda2 rhgb quiet
  [Linux-bzImage, setup=0x1e00, size=0x1b6885]
initrd /boot/initrd-2.6.13-1.1526_FC4.img
  [Linux_initrd @ 0x2fe9d000, 0x12c6dc bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 4.2.15 starting
mount: error 6 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup'ing fd of 0 to 0
error dup'ing fd of 0 to 1
error dup'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

that's all.

and Yes !, booting with hda=noprobe fix the problem, the system boot.

but there is still the "no dma" problem on the dvd drive
hdparm -d /dev/hdc give : using_dma = 0 (off)

and trying hdparm -d 1 /dev/hdc give an HDIO_SET_DMA failed: Operation not permitted
( im am root ) 

this dma problem, was here ( on the inspiron 9300) for every kernel, 
and a way to fix this is to disable IDE subsystem ( compiled as module, but
unused ) and enable ATAPI/PATA in libata.h !

I'll be interested if you can give an easiest way !

Best Regards  
Comment 6 Gael Fraiteur 2005-10-09 13:46:36 EDT
I tried both fixes (hda=noprobe and Daniel's CONFIG_IKCONFIG*=y) and... nothing
works on my machine.
Comment 7 Ingemar Nilsson 2005-10-10 15:59:28 EDT
I have exactly this problem (my system is a Dell Latitude D810). The hda=noprobe
workaround works for me.
Comment 8 Troy Monaghen 2005-10-11 09:46:00 EDT
I seem to have the same or a similar problem with kernel 1526 on a Toshiba
A75-S231, but hda=noprobe des not wortk and I do get a few more messages at boot.

Uncompressing linux... Ok, booting the kernel.
Red hat nach version 4.2.15 starting
insmod error inserting '/lib/dm-mod.ko': -1 Operation not permitted
ERROR: /bin/insmod exited abnormally wth value 1 (pid 348)
insmod error inserting '/lib/dm-mirror.ko': -1 unknown symbol in module
ERROR: /bin/insmod exited abnormally wth value 1 (pid 357)
insmod error inserting '/lib/dm-zero.ko': -1 unknown symbol in module
ERROR: /bin/insmod exited abnormally wth value 1 (pid 358)
insmod error inserting '/lib/dm-snapshot.ko': -1 unknown symbol in module
ERROR: /bin/insmod exited abnormally wth value 1 (pid 359)
Unable to find device-mapper major/minor
  Reading all physical volumes - This may take a while
  No volume groups found
  Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally with value 5! (pid 362)
mount: error 6 mounting ext3
ERROR opening /dev/console!!!! : 2
error duping fd of 0 to 0
error duping fd of 0 to 1
error duping fd of 0 to 2
switchroot: mount failed: 22
kernel panic - not syncing: Attempt to kill init!
Comment 9 Troy Monaghen 2005-10-11 13:33:29 EDT
I just found another bug that looks similar... #169675.  I tried disabling
hyperthreading in my BIOS as was mentioned in that bug and it allowed the kernel
to boot.
Comment 10 Miloš Komarčević 2005-10-12 16:50:39 EDT
I also started experiencing similar issues after upgrading to 2.6.13-1.1526_FC4
on my IBM TP 600E (PIIX4 IDE controller, and Pentium II, so no hyperthreading
there). The system worked fine with 2.6.12-1.1456_FC4.

If I boot with the usual options, I get dma timeouts, identical to the ones
reported in bug #132584 (the top few lines are there just as indication for
where it happens in the boot rpocess but I don' think I transcribed them correctly)

Switching root
unmounting /dev/console
input: ps/2 mouse detected
hda: dma_timer_expiry: dma status == 0x21
hda: DMA timeout error
hda: dma timeout error: status=0x58 { DriveReady SeekComplete DataRequest }
ide: failed opcode was: unknown

I tried hda=noprobe, but that gives me the kernel panic reported in comment #5
and hda=nodma gives me the dma timeouts again.
Comment 11 Stephen Walton 2005-10-13 14:48:21 EDT
I have two Dell Precision 350 workstations and a Precision 360 which show the
same symptom as the original poster (error 6 mounting ext3 etc.) on the 2.6.13
kernel.  hda=noprobe doesn't help, which didn't surprise me as these systems
have SCSI disks.  On the other hand, two Dell Precision 450 systems (dual Xeons)
work fine with the current 2.6.13 release.

Here's the complete error output, hand transcribed:

Uncompressing Linux... Ok, booting the kernel.
hda: No disk in drive
Red Hat nash version 4.2.15 starting
  Reading all physical volumes.  This may take a while...
hda: No disk in drive
  No volume groups found
hda: No disk in drive
  Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally with value 5 ! (pid 359)
mount: error 6 mounting ext3

following which the same messages appear as above.
Comment 12 Hugh Emberson 2005-10-18 02:20:56 EDT
It hangs on my Dell Ispiron 5150 just after printing:

Uncompressing Linux... Ok, booting the kernel.
Comment 13 Hugh Emberson 2005-10-18 02:24:44 EDT
Sorry, that should have read:

It hangs on my Dell Ispiron 5150 just after printing:

   Uncompressing Linux... Ok, booting the kernel.

I'm using the SMP package kernel-smp-2.6.13-1.1526_FC4.  My 5150 has a Pentium
IV with HT.

kernel-smp-2.6.12-1.1447_FC4 works fine.
Comment 14 Miloš Komarčević 2005-10-23 06:55:58 EDT
The latest update kernel-2.6.13-1.1532_FC4 still gives me the same problems on
my TP 600E as in comment #10
Comment 15 Daniel Roche 2005-10-24 03:37:40 EDT
updating to kernel-2.6.13-1.1532_FC4 fix the problem for the inspiron 9300 !
( don't crash any more, but still does not use DMA on the cd/dvd )
Comment 16 Stephen Walton 2005-10-28 11:16:47 EDT
My problem with this kernel turns out to be a rearrangement of the MPT SCSI
driver between 2.6.12 and 2.6.13, with the result that the needed modules were
not making it into the initrd.  I found the fix at
http://forums.fedoraforum.org/showthread.php?p=387546, and used the following
command to build a new RAM disk:

/sbin/mkinitrd --preload mptbase --preload mptscsih --preload mptspi --preload
mptfc /boot/initrd-2.6.13-1.1526_FC4.preload-scsi.img 2.6.13-1.1526_FC4

(substitute your kernel version).  This fixed my 350 and 360 Dell workstations.

Note You need to log in before you can comment on or make changes to this bug.