Bug 169695 - Flood of debug messages from w83781d sensor
Flood of debug messages from w83781d sensor
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 09:20 EDT by Steve Snyder
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 00:45:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2005-10-01 09:20:26 EDT
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux i686; U; en)

Description of problem:
dmesg is filled with this message: "w83781d 1-0290: Starting device update".  
This constant stream of messages is caused by the W83781D hardware sensor driver 
 and is a result of CONFIG_HWMON_DEBUG_CHIP being enabled in the current FC4 
kernel.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1.Boot 2.6.13-1.1526_FC4 kernel
2.Load W83781D device driver
3.Run any application that monitors system health (e.g. gkrellm)
4.Run dmesg to show it is filled with the debug message

Actual Results:  running dmesg shows only repeated entried of this debug message, pushing out all 
other information.

Expected Results:  Massive output of driver debug information should not be enabled by default.


Additional info:

Please do not enable CONFIG_HWMON_DEBUG_CHIP in future kernel releases.
Comment 1 Dave Jones 2005-10-02 17:14:34 EDT
fixed in cvs, will be in next errata.
Comment 2 Dave Jones 2005-11-10 14:40:06 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.