Bug 169712 - mkinitrd breaks processing of kernel boot arguments
mkinitrd breaks processing of kernel boot arguments
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 16:55 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 12:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-10-01 16:55:08 EDT
Description of problem:

With initrd created with mkinitrd 5.0.2-1 or 5.0.3-1 arguments like
bootlevel are ignored and a machine boots always to what is specified
in /etc/inittab.  This is not the case for an older kernel which I have
here and which is still using initrd done with 5.0.0-1; but if I replace
initrd for this kernel with a new one redone with 5.0.3-1 then an argument
specifying a desired boot level is immediately ignored.

Version-Release number of selected component (if applicable):
mkinitrd-5.0.2-1 and mkinitrd-5.0.3-1

How reproducible:
always
Comment 1 Sammy 2005-10-03 11:17:48 EDT
I can't even build a initrd image with older versions of 2.6.13 kernels. I am getting 
 
"cannot find module modprobe (aborting)" 
 
message and nothing is produced. Version 5.0.0 works perfectly but 5.0.2 and .3 does not. 
 
If this is due to kernel incompatibility then there should be a Requisite of some sort. 
Thanks 
Comment 2 Peter Jones 2005-10-07 12:45:33 EDT
mkinitrd-5.0.4-1 should have command line parsing working again.

Note You need to log in before you can comment on or make changes to this bug.