This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 169714 - RFE - scan directory for configuration files
RFE - scan directory for configuration files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 17:35 EDT by Michael A. Peters
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 09:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2005-10-01 17:35:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
In the /etc/fonts/fonts.conf file - there are a lot of settings specific to particular fonts. If one needs to set similar settings to other fonts globally for the system, they must go into /etc/fonts/local.conf - but it would be better if there could be a directory where individual configuration files for fonts could be placed.

That would allow an individual font family rpm to own a configuration file for how that font is to be handled, which would make it easy for the rpm maintainer to keep that uptodate if changes need to made.

Currently, the only available mechanism is to have the font rpm modify /etc/fonts/local.conf but that is not acceptable since that file should be maintained by the system administrator to contain settings that take precedence over the default settings.

Version-Release number of selected component (if applicable):
fontconfig-2.2.3-13

How reproducible:
Always

Steps to Reproduce:
1. N/A
2. N/A
3. N/A
  

Actual Results:  N/A

Expected Results:  N/A

Additional info:

This RFE might need to be dealt with upstream instead of here.
Comment 1 Michael A. Peters 2005-10-06 07:51:31 EDT
Looks like this has already been in upstream for next version

http://www.fontconfig.org/wiki/2_2e3_20release_20notes
Comment 2 Michael A. Peters 2005-12-19 09:25:21 EST
This is in rawhide.

Note You need to log in before you can comment on or make changes to this bug.