Bug 169718 - sis900 ethernet device works with custom kernel but not with fc3 kernel
sis900 ethernet device works with custom kernel but not with fc3 kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-10-01 21:13 EDT by thewade
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-08 14:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
the results of sysreport in FC3-i386 (189.50 KB, application/octet-stream)
2005-10-05 16:12 EDT, thewade
no flags Details
2.6.13-rc4-RT-V0.7.53-02 .config file (working kernel config file) (50.47 KB, text/plain)
2005-10-10 20:30 EDT, thewade
no flags Details

  None (edit)
Description thewade 2005-10-01 21:13:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
My system is an X86_64 AMD 64-bit laptop running FC3 i386

I used to use a custom RLimits enabled kernel and (possibly) had my modem (attached to my ethernet device) disabled, and my ethernet device worked. Now that I have switched to the standard FC3 kernel (so that livna's ati kernel modules will work) my ethernet device does not work. I wonder if this is a bug related to the modem.

Can I disable the modem some how to test to see if that is even the problem?
(I am using i386 because a piece of software I use needs to be in i386 to work properly: arrays in Pure-Data)

One hint is that before I only had two sound cards, the RME and the intel_8X (or something). Now an intel_8Xm (or something with the 'm' suffix) and three sound cards show up.

here is the result of lspci:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 755 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
00:09.0 CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus MultiMediaBay Controller (rev 20)
00:09.1 CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus MultiMediaBay Controller (rev 20)
00:09.2 System peripheral: O2 Micro, Inc. OZ711Mx MultiMediaBay Accelerator
00:0b.0 Network controller: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
02:00.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall DSP (rev 0b)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC3 kernel or use rescue disc
2. ethernet device fails to send or recieve packets, even in permiscious mode


Actual Results:  zilch

Expected Results:  I should be able to at least see packets and send packets

Additional info:
Comment 1 John W. Linville 2005-10-03 09:33:52 EDT
Please attach the output of running "sysreport" (while running the FC3 
What kernel version were you using before?  With 2.6.12-1.1378_FC3, does the 
kernel seem to think it can access the device?  (i.e. does it "see" eth0?) 
Comment 2 thewade 2005-10-03 16:30:05 EDT
As I cannot use the device on any network, I will transcribe the results of
sysreport once I get home. As far as 'seeing' eth0, I can:
ifconfig eth0 x.x.x.x netmask x.x.x.x
ifconfig eth0 up
ifconfig eth0 - outputs info that looks as it should.
route add default gw x.x.x.x

but ping gateway fails even to make lights blink on my switch.
The other kernel was (I am sure of everything through V0.7):
using kernel.org's 2.6.12, the 2.6.13-rc3 patch, and Ingos RT patch. I abandoned
this kernel as I wanted to try to use livna's ati-flgrx kernel module hoping it
would speed up my system, but I cant get my system on the net to get things set
up correctly... Becasue of this and other problems.

I will update with the results of sysreport tomarrow, as I have to bike home,
run the report, then bike back to starf**ks to use their wireless to check my
mail and update this page.

Thank you for the help! If I can get an iso image of FC4 downloaded and burned
correctly I will try to install/upgrade-to that. (Windows won't let me burn the
DVD version on one machine becasue of it not being encoded in (UDF?) mode, and
on another perhaps because of the media the other machine uses (I am trying to
resolve this next).
Comment 3 thewade 2005-10-05 16:11:45 EDT
(In reply to comment #1)
> Please attach the output of running "sysreport" (while running the FC3 
> kernel)...thanks!  
> What kernel version were you using before?  With 2.6.12-1.1378_FC3, does the 
> kernel seem to think it can access the device?  (i.e. does it "see" eth0?) 

I have attached sysreport. Hope it helps!

Also I upgraded to FC4, but the problem still exists. Consequently to get the CD
to boot past loading initrd.img.......... I had to do linux <enter>, then
<ctrl-c> to abort before initrd was finished loading: then redo linux <enter>.
Otherwise my machine would just reboot with no output immediately after initrd
was done loading. I tried linux - noprob, skipddc, resolution=1280x800, nofb,
text; all to no avail.
Comment 4 thewade 2005-10-05 16:12:47 EDT
Created attachment 119649 [details]
the results of sysreport in FC3-i386
Comment 5 John W. Linville 2005-10-07 10:03:46 EDT
Odd...there is _no_ difference between the current upstream sis900 driver and 
what is currently in FC4.  Are you running the latest FC4 kernel? 
Could you attach the config for the custom kernel you are using that works? 
Comment 6 thewade 2005-10-07 19:06:58 EDT
I will post the kernel.config file for the custom kernel, but again I will have
to wait till tomarrow, as I have to go home, boot my laptop to linux, burn it
onto CD, boot back to winblows, and copy it back from the CD in order to get it
too you. What a pain! I REALLY need to get internet going at my appartment, but
then again I also REALLY need to get a job.

I hope I wasn't confusing earlier: the sis900 dosn't work on FC3 _OR_ FC4
standard kernels. I guess I sont know what you mean by 'upstream'. The FC4
kernel I am using is either the old FC3 kernel or the FC4 kernel that is on the
DVD.iso image (as of perhaps a month ago), depending on if the kernel image on
the DVD is older then the FC3 kernel that I downloaded by rpm only a couple of
weeks ago. I don't know if there are any FC4 specific kernel mods... I guess I
am also confused as to what the main differences are between FC3 and FC4,
besides cleaned up gnome apps and such.
Comment 7 thewade 2005-10-08 18:25:17 EDT
I forgot to bring the .config file over on the train today. Sorry.
I am trying to upgrade the kernel to the latest FC4 kernel to see if that fixes 

Also, as an aside, I am trying to rebuild jack for the FC4 kernel and I keep 
getting a "present but cannot be compiled" warning from configure for 
readline/chardefs.h, and make dies. I have the kernel-devel package installed 
for my kernel (I am pritty sure). Any ideas there either?
Thanks again! Until tomarrow.
Comment 8 thewade 2005-10-10 20:30:04 EDT
Created attachment 119789 [details]
2.6.13-rc4-RT-V0.7.53-02 .config file (working kernel config file)

This is the kernel I was running before I went back to the mainline FC kernels:
2.6.16 base
2.6.13-rc4 patch
Ingo M.'s RT realtime-preempt patch
Comment 9 thewade 2005-10-18 16:24:58 EDT
Alright, Im getting very "bummed out". This is my main performance computer and
I am basically sitting around kicking myself for being an idiot, doing nothing.
(this is a rant directed at the fates, not at the developers who are trying to
help me)

I bit the bullet and formatted and reinstalled: no dice damit!

I bought a PCMCIA ethernet card (just in case linux was failing on some error
that windows ignores (what is the world coming too when windows can use an
ethernet device that linux can't?): I would ping, wait for a LONG time and
packets would come back with at between 10,000 and 20,000ms response time.
dhclient would find an ip but I couldnt run really anything. webpages would
eventually load but yum and rpm for remote packages all fail.

So I figure its some module that is interfearing with packets, right...
I try to rmmod a bunch of modules (like paraport, paraport_lc (i think), lp) no
I mv bluetooth and l2cap .ko files and reboot (as rmmod would not let me remove
the modules even with -f flag): no dice.

Now I check /var/log/messages: WOW errors!
(transcribed by hand - please forgive)
Oct 18 12:59:27 musicbox dhclient: DHCPDISCOVER on eth0 port 67
interval 8
Oct 18 12:59:34 musicbox kernel: NETDEV WATCHDOG: eth0: transmit timed out
Oct 18 12:59:34 musicbox kernel: eth0: Transmit timeout, status 00000000 00000240
Oct 18 12:59:35 musicbox dhclient: DHCPDISCOVER on eth0 port 67
interval 9
Oct 18 12:59:42 musicbox kernel: NETDEV WATCHDOG: eth0: transmit timed out
Oct 18 12:59:42 musicbox kernel: eth0: Transmit timeout, status 00000000 00000260

I now have 2 questions:
1. what is the status code 00000000 00000240 (& 260) refering to?
2. how do packets move in linux? For example I send a ping -> it gets encoded
into TCP, wrapped in IP, wrapped in link layer, ?iptables firewall gets packet?,
?packet sent to the kernel module sis900?, ?kernel module sis900 puts packet on
wire?. (?xxx? denotes guess)
I wonder what modules can stop packet flow, 'cause I disable the firewall and
that clearly does nothing.

Oh, and selinux is disabled.

Thanks for all the help! Please help me soon, lest I surely go totally insane
and flay myself. 
Comment 10 John W. Linville 2005-10-18 16:28:44 EDT
It sounds as if your interrupts are not properly routed...? 
By chance, have you tried booting with "acpi=noirq" or "acpi=off" on the 
kernel command line? 
Comment 11 thewade 2005-10-18 17:32:52 EDT
Oh sweet sugger mama!
acpo=noirq did not change anything (that I could see) but acpi=off!
curse you acpi!

So, what does this mean for system perfomance and features?
Is this a perminant situation: no acpi if I choose to use the FC4 standard kernel?

Thanks for saving me from the rack!
If you want to debug acpi and the sis900 send me kernels or sis900 modules or
something. I imagine that my sistem will run better/faster/cleaner the less
kernel parameters I have to pass.
Comment 12 John W. Linville 2005-10-20 11:11:21 EDT
You may want to pursue a BIOS upgrade if one is available.  What 
motherboard/system is this? 
Comment 13 thewade 2005-10-20 13:06:31 EDT
Xtremenotebooks Reactor (now, I think they have changed the model names, and
certanly the prices, sence I bought mine) AMD64 3400+ notebook. I have never
flashed the bios, but sence I bought this after 2000, I believe in 2004 or
perhaps 2003, linux acpi should work... Or so this perpetual newbie reasons.
I will look into it! Thank you!

PS: What performance hit, if any, do I take using the standard FC4 kernel
without acpi?
Comment 14 John W. Linville 2005-11-08 10:31:04 EST
Please take a look at bug 156001 comment 11.  Does disabling irqbalance (and 
removing "acpi=off") result in a working system for you? 
Comment 15 thewade 2005-11-08 13:58:24 EST
I don't think i have irqbalance installed. Should I...?

sudo /sbin/chkconfig irqbalance off
error reading information on service irqbalance: No such file or directory
Comment 16 John W. Linville 2005-11-08 14:05:04 EST
Well, it was just a thought...most people prefer not to disable ACPI if they 
don't have to do so...sorry! 
Anyway, I'm going to close this as CANTFIX since it seems clearly related to 
an ACPI BIOS issue. 

Note You need to log in before you can comment on or make changes to this bug.