Bug 1697206 - apiserver received an error about kube:admin
Summary: apiserver received an error about kube:admin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Mo
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 04:45 UTC by shahan
Modified: 2019-06-04 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:15 UTC

Description shahan 2019-04-08 04:45:31 UTC
Description of problem:
apiserver received an error about kube:admin
 
Version-Release number of selected component (if applicable):
Cluster version is 4.0.0-0.10

How reproducible:
always

Steps to Reproduce:
1. $ oc logs apiserver-7qqf4 -n openshift-apiserver
2.
3.

Actual results:
[hasha@fedora_pc ~]$ oc logs apiserver-7qqf4 -n openshift-apiserver |grep "received an error"
E0408 02:49:12.892309       1 status.go:64] apiserver received an error that is not an metav1.Status: &field.Error{Type:"FieldValueInvalid", Field:"metadata.name", BadValue:"kube:admin", Detail:"may not contain \":\""}
E0408 02:49:24.941625       1 status.go:64] apiserver received an error that is not an metav1.Status: &field.Error{Type:"FieldValueInvalid", Field:"metadata.name", BadValue:"kube:admin", Detail:"may not contain \":\""}
EField:"metadata.name", BadValue:"kube:admin", Detail:"may not contain \":\""}
E0408 02:53:16.347123       1 status.go:64] apiserver received an error that is not an metav1.Status: &field.Error{Type:"FieldValueInvalid", Field:"metadata.name", BadValue:"kube:admin", Detail:"may not contain \":\""}
E0408 02:53:47.752210       1 status.go:64] apiserver received an error that is not an metav1.Status: &field.Error{Type:"FieldValueInvalid", Field:"metadata.name", BadValue:"kube:admin", Detail:"may not contain \":\""}


Expected results:
should have no this kind of error

Additional info:

Comment 1 Michal Fojtik 2019-04-08 08:44:27 UTC
I suspect this to be some admission webhook or something that API server is making requests to (oauth?)

Mo, any ideas?

(setting severity low to get this off the blocker list as this is likely just some misconfiguration and it is not breaking the cluster)

Comment 4 shahan 2019-05-10 02:56:39 UTC
$ oc get user 'kube:admin'
The User "kube:admin" is invalid: metadata.name: Invalid value: "kube:admin": may not contain ":"
[hasha@fedora_pc ~]$ oc logs apiserver-bh9cn -n openshift-apiserver |grep "received an error"
[hasha@fedora_pc ~]$ 

$ oc get clusterversion
NAME      VERSION      AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-rc.2   True        False         71m     Cluster version is 4.1.0-rc.2

 Verified this bug

Comment 6 errata-xmlrpc 2019-06-04 10:47:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.