Bug 1697222 - haproxy in router image should be updated to latest 1.8.17
Summary: haproxy in router image should be updated to latest 1.8.17
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Luke Meyer
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 06:26 UTC by Hongan Li
Modified: 2019-06-04 10:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:15 UTC

Description Hongan Li 2019-04-08 06:26:55 UTC
Description of problem:
Check the haproxy version of router image and it still use haproxy18-1.8.14-2.el7.x86_64

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-04-132405

How reproducible:
100%

Steps to Reproduce:
1. 
$ oc -n openshift-ingress rsh router-default-98f565474-fp72n

sh-4.2$ haproxy -v
HA-Proxy version 1.8.14-52e4d43 2018/09/20
Copyright 2000-2018 Willy Tarreau <willy@haproxy.org>

sh-4.2$ rpm -qa | grep haproxy
haproxy18-1.8.14-2.el7.x86_64

2.

Actual results:
haproxy version is 1.8.14

Expected results:
haproxy version is 1.8.17

Additional info:
haproxy in OCP 3.11/10 has been updated to 1.8.17

Comment 2 Luke Meyer 2019-04-22 18:11:35 UTC
Was not tagged for 4.1, I think it was getting version from RHEL/Extras or something.

I tagged haproxy-1.8.17-3.el7 -- should show up in next build of the image.

Comment 5 Hongan Li 2019-04-24 03:05:10 UTC
verified with 4.1.0-0.nightly-2019-04-23-223857 and issue has been fixed.

router image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:ed5eee91ebeac7e8ca48e7308f33abaa01b786412aff46a849bb4d847b270b02

$ oc -n openshift-ingress rsh router-default-555c474c6f-b9hkt
sh-4.2$ haproxy -v
HA-Proxy version 1.8.17 2019/01/08
Copyright 2000-2019 Willy Tarreau <willy@haproxy.org>

sh-4.2$ rpm -qa | grep haproxy
haproxy18-1.8.17-3.el7.x86_64
sh-4.2$

Comment 7 errata-xmlrpc 2019-06-04 10:47:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.