Bug 1697225 - Reveal Values will hide data automatically after a few seconds.
Summary: Reveal Values will hide data automatically after a few seconds.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 06:34 UTC by XiaochuanWang
Modified: 2019-06-04 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: API discovery problem. Consequence: Re-mouting of the SecretData component Fix: Fixing the API discovery issue Result: SecretData component is not being re-mounted
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
issue recording (470.28 KB, image/gif)
2019-04-09 08:00 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:15 UTC

Description XiaochuanWang 2019-04-08 06:34:29 UTC
Description of problem:
When user click "Reveal Values", the data will be hidden again automatically after about 3 seconds.

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-05-165550


How reproducible:
Always

Steps to Reproduce:
1. User create a secret by such as:
oc create secret generic my-secret --from-literal=key1=supersecret --from-literal=key2=topsecret
2. On secret detail page, click "Reveal Values", check the data and wait for a few seconds.


Actual results:
2. The data is automatically hidden after about 3 seconds.

Expected results:
3. The data should be displaying well.

Additional info:

Comment 1 Jakub Hadvig 2019-04-08 10:30:45 UTC
Tried to reproduce the issue of Chrome, FF, Safari but without luck.
Could you please provide more info about your setup(browser version, ...) ?

Comment 2 XiaochuanWang 2019-04-09 07:17:23 UTC
Reproduced on:
Chrome 71.0.3578.98 
FF 64.0.2
Please refer to the screenshot for Chrome 73 on MacOS: http://g.recordit.co/3YO3nLBzSX.gif

Comment 3 XiaochuanWang 2019-04-09 08:00:44 UTC
Created attachment 1553798 [details]
issue recording

Comment 5 XiaochuanWang 2019-04-19 01:53:58 UTC
This is not reproduced on lastest OCP version: 4.0.0-0.nightly-2019-04-18-190537
Move it to Verified.

Comment 7 errata-xmlrpc 2019-06-04 10:47:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.