Bug 1697269 - Image Repository cannot update to user-defined externalRegistryHostnames if default route is disabled
Summary: Image Repository cannot update to user-defined externalRegistryHostnames if d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 08:48 UTC by Wenjing Zheng
Modified: 2019-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:15 UTC

Description Wenjing Zheng 2019-04-08 08:48:39 UTC
Description of problem:
Image Repository cannot update to user-defined externalRegistryHostnames when there is no default route (enabled at first then disabled):
$ oc get routes
NAME      HOST/PORT                                                                      PATH   SERVICES         PORT    TERMINATION   WILDCARD
myroute   user-route-openshift-image-registry.apps.xiuwang.qe.devcluster.openshift.com          image-registry   <all>   reencrypt     None
$ oc get is -n openshift
NAME                                           IMAGE REPOSITORY                                                                                                                                TAGS                                              UPDATED
apicast-gateway                                default-route-openshift-image-registry.apps.qe-xiuwang-408.qe.devcluster.openshift.com/openshift/apicast-gateway                                2.1.0.GA,2.2.0.GA,2.3.0.GA,2.4.0.GA + 1 more...   6 hours ago
apicurito-ui                                   default-route-openshift-image-registry.apps.qe-xiuwang-408.qe.devcluster.openshift.com/openshift/apicurito-ui                                   1.2                                               6 hours ago
cli                                            default-route-openshift-image-registry.apps.qe-xiuwang-408.qe.devcluster.openshift.com/openshift/cli                                            latest                                            6 hours ago

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-05-165550
$ oc get pods/image-registry-64c75dc575-2lmpm -o yaml | grep imageID
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:7dbbfe4476239742854a624b012f75a2737846999404bc2d33630c6bd2066e18

How reproducible:
Always

Steps to Reproduce:
1.Enable default routes
$oc patch configs.imageregistry.operator.openshift.io cluster -p '{"spec":{"defaultRoute":true}}' --type='merge' -n openshift-image-registry
$oc get routes -n openshift-image-registry
2.Create additional routes by populating spec.Routes with additional routes
$oc edit configs.imageregistry.operator.openshift.io
spec:
  routes:
  - hostname: user-route-openshift-image-registry.apps.xiuwang.qe.devcluster.openshift.com
    name: myroute
    secretName: ""
3.Disable default route
$oc patch configs.imageregistry.operator.openshift.io cluster -p '{"spec":{"defaultRoute":false}}' --type='merge' -n openshift-image-registry
4.$ oc get is -n openshift

Actual results:
It still uses default-route-openshift-image-registry.apps.xxxxx.

Expected results:
Should update to user-route-openshift-image-registry.apps.xiuwang.qe.devcluster.openshift.com.

Additional info:

Comment 3 Wenjing Zheng 2019-04-10 06:01:22 UTC
I cannot reproduce it now, so moving to verified:4.0.0-0.ci-2019-04-10-002527

Comment 5 errata-xmlrpc 2019-06-04 10:47:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.