Bug 1697290 - systemd-udev-242~rc3-1.fc31: systemd-udevd.service fails with exit code=exited, status=226/NAMESPACE
Summary: systemd-udev-242~rc3-1.fc31: systemd-udevd.service fails with exit code=exite...
Keywords:
Status: CLOSED DUPLICATE of bug 1697370
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 09:58 UTC by Petr Pisar
Modified: 2019-04-12 07:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 14:06:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2019-04-08 09:58:27 UTC
After upgrading systemd-udev from 241-4.gitcbf14c9.fc31.x86_64 to 242~rc3-1.fc31.x86_64 eth0 network interface stops being renamed to ens3. This results into nonconfigured network and making the machine unreachable over a network.

The network interface is a virtio device handled by virtio_net kernel module.
There is another strange thing that the kernel module is not loaded automatically. Loading it manually creates eth0 interface, but udev seems not renaming it.

After a reboot, "systemctl list-units --failed" reports these failed services:

network.service (because the renamed ens3 interface does not exist)
systemd-udevd.service (exit code=exited, status=226/NAMESPACE; follwed by "start  request repeated to quickly")
systemd-udevd-control.socket (service-start-limit-hit)
systemd-udevd-kernel.socket (service-start-limit-hit)

There seems to be some issue with namespaces in udevd daemon.


Please note that I observe this error message from DNF on the upgrade:

  Running scriptlet: systemd-udev-242~rc3-1.fc31.x86_64                                                                                                                          14/14 
Failed to send reload request: No such file or directory
warning: %triggerin(systemd-udev-242~rc3-1.fc31.x86_64) scriptlet failed, exit status 1

Error in <unknown> scriptlet in rpm package systemd-udev


That maybe depends on this scriptlet error:

  Running scriptlet: systemd-libs-242~rc3-1.fc31.x86_64                                                                                                                            1/1 
warning: Unable to get systemd shutdown inhibition lock: Failed to connect to socket /run/dbus/system_bus_socket: No such file or directory

That's caused probably by a broken DBus unit (bug #1623781).

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-04-11 14:06:41 UTC

*** This bug has been marked as a duplicate of bug 1697370 ***

Comment 2 Petr Pisar 2019-04-12 07:32:45 UTC
After disabling SELinux enforcing I was able to upgrade, reboot and udevd started succesfully. Then I enabled enforcing and tried to downgrade, reboot, upgrade, and reboot to reproduce this issue. But I was unable. Now any upgrade to systemd-udev-242~rc3-1.fc31.x86_64 passes for me. I have selinux-policy-3.14.4-9.fc31.noarch.


Note You need to log in before you can comment on or make changes to this bug.