Bug 1697329 - Advanced dialog stays open when closing parent dialog window for libreswan's "IPsec based VPN" connection
Summary: Advanced dialog stays open when closing parent dialog window for libreswan's ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager-libreswan
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Francesco Giudici
QA Contact: Desktop QE
Marc Muehlfeld
URL:
Whiteboard:
: 1697326 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 11:27 UTC by Filip Pokryvka
Modified: 2019-11-05 22:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
.The `gnome-control-center` application now supports editing advanced IPsec settings Previously, the `gnome-control-center` application only displayed the advanced options of IPsec VPN connections. Consequently, users could not change these settings. With this update, the fields in the advanced settings are now editable, and users can save the changes.
Clone Of:
Environment:
Last Closed: 2019-11-05 22:29:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3623 None None None 2019-11-05 22:29:56 UTC

Description Filip Pokryvka 2019-04-08 11:27:19 UTC
Description of problem:
When adding or modifying "IPsec based VPN" connection, the "IPsec Advanced options" dialog does not lock it's parent dialog. It is even possible to close the parent dialog and advanced dialog stays open.

Version-Release number of selected component (if applicable):
NetworkManager-libreswan-gnome-1.2.10-3.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. open nm-connection-editor
2. add (or modify) "IPsec based VPN" connection
3. click "Advanced" in "Identity" tab.
4. close parent window (with the "Identity" tab)

Actual results:
parent window is closed, but advanced dialog remains open

Expected results:
parent window should not be editable and its close button should be disabled

Additional info:
might be causing also: https://bugzilla.redhat.com/show_bug.cgi?id=1697326

Comment 1 Francesco Giudici 2019-04-15 12:56:13 UTC
*** Bug 1697326 has been marked as a duplicate of this bug. ***

Comment 2 Francesco Giudici 2019-04-15 13:19:01 UTC
Fixed upstream:
https://gitlab.gnome.org/GNOME/NetworkManager-libreswan/commit/eaf501ab7cb7

Comment 9 Pavlin Georgiev 2019-07-17 10:18:24 UTC
TEST SETUP
Distro: RHEL-8.1.0-20190701.0
Component version: NetworkManager-libreswan-1.2.10-3.el8


TEST PROCEDURE
1. Install distro RHEL-8.1.0-20190701.0.
2. Download from Brew server and install NetworkManager-libreswan-gnome-1.2.10-4.el8.
3. Reproduce the bug.


RESULT
Upgrading component: NetworkManager-libreswan
    from: 1.2.10-3.el8
      to: 1.2.10-4.el8
has fixed the bug.

Comment 13 errata-xmlrpc 2019-11-05 22:29:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3623


Note You need to log in before you can comment on or make changes to this bug.