Bug 1697679 - [3.10][crio-tool] Installing or upgrading OCP 3.10 when using crio, keeps changing the crictl.yaml file with the incorrect pathvim
Summary: [3.10][crio-tool] Installing or upgrading OCP 3.10 when using crio, keeps cha...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: All
OS: All
medium
low
Target Milestone: ---
: 3.10.z
Assignee: Joseph Callen
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On: 1694106
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-09 02:38 UTC by Weihua Meng
Modified: 2019-06-11 09:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1694106
Environment:
Last Closed: 2019-06-11 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0786 None None None 2019-06-11 09:30:59 UTC

Description Weihua Meng 2019-04-09 02:38:17 UTC
3.10 has the same issue.
openshift-ansible-3.10.122-1.git.0.05498cb.el7

+++ This bug was initially created as a clone of Bug #1694106 +++

Description of problem:
The file /etc/crictl.yaml keeps being updated with the incorrect runtime-endpoint and it needs to be change after running installation or upgrade playbooks, otherwise we get always a warning message when using crictl tool saying the runtime-endpoint is incorrect.

"Using "/var/run/crio/crio.sock" as endpoint is deprecated, please consider using full url format "unix:///var/run/crio/crio.sock""

Version-Release number of the following components:
rpm -q openshift-ansible
openshift-ansible-3.11.92-1.git.0.f2fade7.el7.noarch

rpm -q ansible
ansible-2.6.15-1.el7ae.noarch

ansible --version
ansible 2.6.15
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /bin/ansible
  python version = 2.7.5 (default, Sep 12 2018, 05:31:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-36)]

How reproducible:
Every time

Steps to Reproduce:
1. Run installation or upgrade playbook
2. Check some object using crictl tool: crictl ps
3. Correct the file and check tool again:
  # echo 'runtime-endpoint: unix:///var/run/crio/crio.sock' > /etc/crictl.yaml
  # crictl ps

Expected results:
Do not change the crictl.yaml file or set to the correct endpoint.

Additional info:
/usr/share/ansible/openshift-ansible/roles/openshift_node/tasks/upgrade.yml

--- Additional comment from Joseph Callen on 2019-04-03 18:40:08 UTC ---

https://github.com/openshift/openshift-ansible/pull/11455

Comment 1 Joseph Callen 2019-04-09 18:37:26 UTC
PR: https://github.com/openshift/openshift-ansible/pull/11478

Comment 2 Joseph Callen 2019-04-15 13:07:39 UTC
In build: openshift-ansible-3.10.137-1

Comment 7 Weihua Meng 2019-04-18 06:22:52 UTC
Fixed.

openshift-ansible-3.10.139-1.git.0.02bc5db.el7

# cat /etc/crictl.yaml 
runtime-endpoint: unix:///var/run/crio/crio.sock

Comment 9 errata-xmlrpc 2019-06-11 09:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0786


Note You need to log in before you can comment on or make changes to this bug.