Bug 16977 - gpm locks keyboard if started before keyboard is used
gpm locks keyboard if started before keyboard is used
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: gpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-25 21:51 EDT by Pakin, Scott
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-25 21:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pakin, Scott 2000-08-25 21:51:00 EDT
Hardware:
   Toshiba Portege 7140CT (i686-based laptop)

Software:
   Raw Hide 20000811 (kernel 2.2.16-21)
   gpm-1.19.3-4

Problem Description:
   I rebooted after finishing the installation of Raw Hide, and found I
   couldn't type anything at the login prompt.  Even ctrl-alt-del was
   ignored.

   After power-cycling, I did an interactive boot, and found the keyboard
   worked fine both during and after that.  I rebooted, doing a
   non-interactive boot, and the keyboard again failed.  I added a script
   to /etc/rc.d/rc3.d that did nothing but input a line and then continue.
   When the script was run before S85gpm, the keyboard was fine.  When the
   script was run after S85gpm, the keyboard was dead.

Workaround:
   I deleted /etc/rc.d/rc3.d/S85gpm, and everything works fine.  I can
   even start up gpm after logging in, and all is well.  It seems gpm is
   unhappy if it starts before the keyboard has been used, but is fine
   afterwards.
Comment 1 Preston Brown 2000-08-29 14:13:40 EDT
does your laptop have a ps/2 type mouse device built in, or usb?

This seems to be endemic to your particular laptop unfortunately, and we don't
have similar problems on other laptops.
Comment 2 Pakin, Scott 2000-08-31 15:26:14 EDT
> ------- Additional comments from pbrown@redhat.com  2000-08-29 14:13 -------
> does your laptop have a ps/2 type mouse device built in, or usb?

It has a PS/2-type mouse device (trackpoint) built in.

Note You need to log in before you can comment on or make changes to this bug.