Bug 169770 - glibc no longer gives correct locale info.
glibc no longer gives correct locale info.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-03 10:18 EDT by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 11:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2005-10-03 10:18:35 EDT
Description of problem:
glibc no longer gives a correct answer to some locale calls.

Test program:

#include <langinfo.h>
#include <stdio.h>

int main(int argc, char** argv)
{
        printf("First weekday: %d\n", (int)nl_langinfo(_NL_TIME_FIRST_WEEKDAY)[0]);
        printf("Week first day: %d\n", nl_langinfo(_NL_TIME_WEEK_1STDAY));

        return 0;
}

Output:

[drzeus@poseidon]$ LC_TIME=sv_SE ./langtest
First weekday: 7
Week first day: 19971130

Expected:
[drzeus@poseidon]$ grep weekday /usr/share/i18n/locales/sv_SE
first_weekday 2

Version-Release number of selected component (if applicable):
glibc-2.3.90-12
glibc-common-2.3.90-12


This bug is causing problems here since it throws off calculation of week
numbers in every application.
Comment 1 Pierre Ossman 2005-10-03 11:32:05 EDT
False alarm. My code misses a setlocale(LC_ALL, ""); so it will of course not work.

The problem must be in GTK+ since it is gtk-based programs that are misbehaving
(calander widget most notably). I'll continue digging. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.