Bug 169771 - after running php file with imagegif() function temp imagefile is not deleted
after running php file with imagegif() function temp imagefile is not deleted
Status: CLOSED DUPLICATE of bug 182719
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-10-03 10:19 EDT by Ferdi
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-12 08:18:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Temp file created in /tmp directory (38.93 KB, image/gif)
2005-11-08 04:30 EST, Ferdi
no flags Details

  None (edit)
Description Ferdi 2005-10-03 10:19:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
The following script should create, show en delete a image.
$im_des= imagecreatefromgif("./maps/DNK.gif");
Every time this script is run, a temp image is created in the /tmp dir. This file is never deleted after the script is ended. Even when I run imagedestroy($im_des) which should release all resources.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. create same file
2. access file


Actual Results:  ls -all /tmp will show temp files like "shQXTz"

Expected Results:  the resources should be released, so the temp file should be deleted.

Additional info:
Comment 1 Phil Knirsch 2005-11-07 11:23:34 EST
Tried reproducing with Red Hat Enterprise Linux 4 Update 2.

I can't find any leftover temp files in /tmp or /var/tmp after running this command.

Maybe the leftover files come from some other place?

Read ya, Phil
Comment 2 Ferdi 2005-11-08 04:30:09 EST
Created attachment 120807 [details]
Temp file created in /tmp directory

An temp file created in the /tmp directory
Comment 3 Ferdi 2005-11-08 04:36:37 EST
I'v attached a tempfile wich is created in the /tmp directory. If you rename 
the file to test.gif, you'll get the image created by the script.
Every time I run the script a extra temp file is created.
Comment 4 Adam Tkac 2006-10-27 09:08:55 EDT
please, could you try reproduce this bug with latest version of php-gd
Comment 5 Joe Orton 2006-12-12 08:18:01 EST
This is fixed in php-4.3.9-3.10 and later.

*** This bug has been marked as a duplicate of 182719 ***

Note You need to log in before you can comment on or make changes to this bug.