Bug 169783 - RHEL 4 U2 x86_64 initrd-xxx.img doesn't have the driver for QLA2342 when installed the OS on it
RHEL 4 U2 x86_64 initrd-xxx.img doesn't have the driver for QLA2342 when inst...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hwdata (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Mike McLean
:
Depends On:
Blocks: 168430
  Show dependency treegraph
 
Reported: 2005-10-03 12:00 EDT by dely.l.sy
Modified: 2015-03-04 20:15 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0068
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for hwdata upgradelist (382 bytes, patch)
2006-02-01 13:07 EST, Jeff Layton
no flags Details | Diff

  None (edit)
Description dely.l.sy 2005-10-03 12:00:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
This problem exists in both RHEL 4 U2 & U1. This is an installer problem. This happens when a Fiber channel expansion card (with device QLA 2322)and QLA2342 are in the system during installation and the OS is istalled on QLA 2342.  
The installation process showed that QLA 2342 was detected and the driver was laoded for it to do installation.  However, after the installation, the kernel didn't boot up.  Unzipping the ramdisk image showed that the lib directory didn't have the qla2300 module and init file didn't have an entry to load qla2300 for QLA2342, even thought the installed tree has the module in /lib/modules directory and modules.conf has an entry for it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Have Fiber Channel extension card (that has qla2322) and QLA2342 on the system
2.Install RHEL 4 U2 on disk attached to QLA2342
3.Reboot system after installation
4.System hangs
  

Additional info:
Comment 7 Jeff Layton 2006-02-01 13:07:17 EST
Created attachment 123982 [details]
patch for hwdata upgradelist

I think I've found the problem. It appears to be due to a typo in the hwdata
upgradelist file. The qla2300 line in that file has the 'new' modulename
misspelled as qal2300. This patch should correct it.

I have not yet seen if this patch will indeed fix the install problem, since
I'd need a new installer, but it did seem to fix the problem with
module_upgrade removing qla2300 from the modprobe.conf file.
Comment 19 Red Hat Bugzilla 2006-03-07 13:07:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0068.html

Note You need to log in before you can comment on or make changes to this bug.