Bug 1697903 - There are 2 different semantic versions of Kubernetes components running.
Summary: There are 2 different semantic versions of Kubernetes components running.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-09 09:33 UTC by Junqi Zhao
Modified: 2019-06-04 10:47 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:29 UTC

Description Junqi Zhao 2019-04-09 09:33:28 UTC
Description of problem:
search kubernetes_build_info{job!="kube-dns"} in prometheus, there are 2 gitVersion, one is gitVersion="v1.12.4+509916ce1, the other is gitVersion="v1.13.4+935f971"

Element	Value
kubernetes_build_info{buildDate="2019-03-28T17:16:44Z",compiler="gc",endpoint="https-metrics",gitCommit="509916ce1",gitTreeState="clean",gitVersion="v1.12.4+509916ce1",goVersion="go1.10.8",instance="10.0.51.169:10250",job="kubelet",major="1",minor="12+",namespace="kube-system",node="ip-10-0-51-169.us-east-2.compute.internal",platform="linux/amd64",service="kubelet"}	1
kubernetes_build_info{buildDate="2019-03-28T17:16:44Z",compiler="gc",endpoint="https-metrics",gitCommit="509916ce1",gitTreeState="clean",gitVersion="v1.12.4+509916ce1",goVersion="go1.10.8",instance="10.0.61.5:10250",job="kubelet",major="1",minor="12+",namespace="kube-system",node="ip-10-0-61-5.us-east-2.compute.internal",platform="linux/amd64",service="kubelet"}	1
kubernetes_build_info{buildDate="2019-03-28T17:16:44Z",compiler="gc",endpoint="https-metrics",gitCommit="509916ce1",gitTreeState="clean",gitVersion="v1.12.4+509916ce1",goVersion="go1.10.8",instance="10.0.73.255:10250",job="kubelet",major="1",minor="12+",namespace="kube-system",node="ip-10-0-73-255.us-east-2.compute.internal",platform="linux/amd64",service="kubelet"}	1
kubernetes_build_info{buildDate="2019-03-28T17:16:44Z",compiler="gc",endpoint="https-metrics",gitCommit="509916ce1",gitTreeState="clean",gitVersion="v1.12.4+509916ce1",goVersion="go1.10.8",instance="10.0.92.244:10250",job="kubelet",major="1",minor="12+",namespace="kube-system",node="ip-10-0-92-244.us-east-2.compute.internal",platform="linux/amd64",service="kubelet"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.51.169:10251",job="scheduler",major="1",minor="13+",namespace="openshift-kube-scheduler",platform="linux/amd64",pod="openshift-kube-scheduler-ip-10-0-51-169.us-east-2.compute.internal",service="scheduler"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.51.169:10252",job="kube-controller-manager",major="1",minor="13+",namespace="openshift-kube-controller-manager",platform="linux/amd64",pod="kube-controller-manager-ip-10-0-51-169.us-east-2.compute.internal",service="kube-controller-manager"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.73.255:10251",job="scheduler",major="1",minor="13+",namespace="openshift-kube-scheduler",platform="linux/amd64",pod="openshift-kube-scheduler-ip-10-0-73-255.us-east-2.compute.internal",service="scheduler"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.73.255:10252",job="kube-controller-manager",major="1",minor="13+",namespace="openshift-kube-controller-manager",platform="linux/amd64",pod="kube-controller-manager-ip-10-0-73-255.us-east-2.compute.internal",service="kube-controller-manager"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.92.244:10251",job="scheduler",major="1",minor="13+",namespace="openshift-kube-scheduler",platform="linux/amd64",pod="openshift-kube-scheduler-ip-10-0-92-244.us-east-2.compute.internal",service="scheduler"}	1
kubernetes_build_info{buildDate="2019-04-04T02:05:24Z",compiler="gc",endpoint="https",gitCommit="935f971",gitTreeState="clean",gitVersion="v1.13.4+935f971",goVersion="go1.10.8",instance="10.0.92.244:10252",job="kube-controller-manager",major="1",minor="13+",namespace="openshift-kube-controller-manager",platform="linux/amd64",pod="kube-controller-manager-ip-10-0-92-244.us-east-2.compute.internal",service="kube-controller-manager"}	1

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-05-165550

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
There are 2 different semantic versions of Kubernetes components running.

Expected results:
Should be one

Additional info:

Comment 6 errata-xmlrpc 2019-06-04 10:47:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.