Bug 1698042 - quick-read cache invalidation feature has the same key of md-cache
Summary: quick-read cache invalidation feature has the same key of md-cache
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quick-read
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1697820
TreeView+ depends on / blocked
 
Reported: 2019-04-09 13:41 UTC by Atin Mukherjee
Modified: 2019-07-08 05:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-08 05:10:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22539 None Merged quick-read: rename cache-invalidation key to avoid redundant keys 2019-07-08 05:10:38 UTC

Description Atin Mukherjee 2019-04-09 13:41:04 UTC
Description of problem:

    With group-metadata-cache group profile settings
    performance.cache-invalidation option when turned on enables both md-cache
    and quick-read xlator's cache-invalidation feature. While the intent of
    the group-metadata-cache is to set md-cache xlator's cache-invalidation
    feature, quick-read xlator also gets affected due to the same. While
    md-cache feature and it's profile existed since release-3.9,
    quick-read cache-invalidation was introduced in release-4 and due to
    this op-version mismatch on any cluster which is >= glusterfs-4 when
    this group profile is applied it breaks backward compatibility with the
    old clients.

Version-Release number of selected component (if applicable):
mainline

Comment 1 Worker Ant 2019-04-09 13:48:26 UTC
REVIEW: https://review.gluster.org/22539 (quick-read: rename cache-invalidation key to avoid redundant keys) posted (#1) for review on master by Atin Mukherjee

Comment 2 Worker Ant 2019-07-08 05:10:39 UTC
REVIEW: https://review.gluster.org/22539 (quick-read: rename cache-invalidation key to avoid redundant keys) merged (#6) on master by Raghavendra G


Note You need to log in before you can comment on or make changes to this bug.