Bug 1698211 - EPEL7 - python-boto3 is now part of Red Hat Entreprise 7.6 base
Summary: EPEL7 - python-boto3 is now part of Red Hat Entreprise 7.6 base
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-boto3
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: EPEL7FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-04-09 19:57 UTC by Troy Dawson
Modified: 2019-07-30 19:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-30 19:59:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Troy Dawson 2019-04-09 19:57:35 UTC
I am trying to cleanup EPEL7 packages.

python-boto3 is now in RHEL 7.6
python2-boto3, that is in EPEL7 will not install, due to python2-s3transfer not being available, because python-s3transfer also being part of RHEL 7.6. 

I believe python-boto3 should be removed from EPEL7.

Please respond to this bug, letting us know if you feel this package should be in EPEL7, or not.

If you wish it removed, let us know and we can have a proven packager remove it from EPEL7.

If you have not responded in two weeks, we will assume that you do not mind it being removed and will have a proven packager remove the package from EPEL7.

Comment 1 Troy Dawson 2019-04-09 20:07:30 UTC
There are two packages that cannot be installed from EPEL7 due to this.
  python2-certbot-dns-route53
  python2-dns-lexicon+route53
I believe we just need to change them so they depend on python-boto3.

Comment 2 Troy Dawson 2019-04-09 20:19:31 UTC
I was wrong in comment #1
Both of those packages depend on python-boto3.
The problem is that python2-boto3 in EPEL7 provides both python-boto3 and python2-boto3.

Removing python2-boto3 will fix both of those packages.

Comment 3 Troy Dawson 2019-04-09 20:59:52 UTC
I might have made a mistake.
I am seeing python-boto3 in Centos7 (7.6.1810), but not in RHEL 7.6.
The epel7 version of python2-boto3 installs successfully on RHEL 7.6.
Investigating why it's in CentOS 7 and not RHEL 7.

Comment 4 Troy Dawson 2019-07-30 19:59:26 UTC
It looks like python2-boto3 is needed to build some CentOS 7 packages, and thus is in CentOS 7.
This is not a bug, sorry about that.


Note You need to log in before you can comment on or make changes to this bug.