Bug 1698250 - [api-freeze] MachineConfigPool machineSelector is confusing
Summary: [api-freeze] MachineConfigPool machineSelector is confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Kirsten Garrison
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-09 22:31 UTC by Derek Carr
Modified: 2019-06-04 10:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:25 UTC

Description Derek Carr 2019-04-09 22:31:08 UTC
Description of problem:
MachineConfigPool matches a set of MachineConfig (machine.spec.machineConfigSelector) with a set of nodes (machine.spec.machineSelector).

machine.spec.machineSelector is confusingly named.

It should be machine.spec.nodeSelector.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Antonio Murdaca 2019-04-12 09:41:51 UTC
PR has been merged with support to the old machineSelector till 04/16 where we're going to drop support for that altogether

Comment 4 Micah Abbott 2019-05-07 16:40:12 UTC
$ oc adm release info   
Name:      4.1.0-0.okd-2019-05-07-124355                                                                               
Digest:    sha256:52168017b3530f38e29dae2de1f3cd165406660a4c6ef9030bdfa5c610ae0cd0                                     
Created:   2019-05-07T12:44:03Z                                                                                        
OS/Arch:   linux/amd64                                                                                                 
Manifests: 289                                                                                                         
                                                                                                                       
Pull From: registry.svc.ci.openshift.org/origin/release@sha256:52168017b3530f38e29dae2de1f3cd165406660a4c6ef9030bdfa5c610ae0cd0
                                                                                                                       
Release Metadata:                                                                                                      
  Version:  4.1.0-0.okd-2019-05-07-124355                                                                              
  Upgrades: <none>                                                                                                     
                                                                                                                       
Component Versions:                                                                                                    
  Kubernetes 1.13.4                                                                                                    
...


$ oc get machineconfigpool master -o yaml | grep -C 5 nodeSelector
spec:
  machineConfigSelector:
    matchLabels:
      machineconfiguration.openshift.io/role: master
  maxUnavailable: null
  nodeSelector:
    matchLabels:
      node-role.kubernetes.io/master: ""
  paused: false
status:
  conditions:

Comment 6 errata-xmlrpc 2019-06-04 10:47:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.