Bug 1698530 - catalog-operator metrics failing to scrape
Summary: catalog-operator metrics failing to scrape
Keywords:
Status: CLOSED DUPLICATE of bug 1689836
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-10 14:23 UTC by Frederic Branczyk
Modified: 2019-04-12 02:34 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-12 02:34:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Frederic Branczyk 2019-04-10 14:23:27 UTC
Description of problem:

The monitoring targets configured in Prometheus are not successfully being scraped. This is causing alerts to fire and SDN metrics not being collected.

```
openshift-operator-lifecycle-manager/catalog-operator/0 (0/1 up) 
Get https://10.128.0.8:8081/metrics: dial tcp 10.128.0.8:8081: connect: connection refused
```

Version-Release number of selected component (if applicable):

4.1

How reproducible:

Always


Steps to Reproduce:
1.
2.
3.

Actual results:

All catalog-operator targets are unsucessfully scraped.

Expected results:

All catalog-operator targets are sucessfully scraped.

Additional info:

Comment 1 Jay Boyd 2019-04-10 14:25:57 UTC
This doesn't look like service catalog, more like OLM.

Comment 2 Frederic Branczyk 2019-04-10 14:28:42 UTC
> This is causing alerts to fire and SDN metrics not being collected.

I meant write catalog-operator here.

> This doesn't look like service catalog, more like OLM.

Ok, thanks for moving! :)

Comment 3 Jian Zhang 2019-04-12 02:34:37 UTC
Hi, Frederic

Thanks for your report! Bug 1689836 is tracing this issue.
I'd like to close this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1689836 ***


Note You need to log in before you can comment on or make changes to this bug.