Bug 169856 - selinux can't open default policy when no sources are installed
selinux can't open default policy when no sources are installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setools (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On: 169853
Blocks: 176344 185483 198694 234547
  Show dependency treegraph
 
Reported: 2005-10-04 10:18 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-10-04 10:18:33 EDT
After having created /etc/selinux/strict/policy (see bug #169853), launching
seinfo will fail to open the default policy:
# seinfo
Could not open policy /etc/selinux/targeted/policy/policy/policy.19!
Attempting to search for another valid policy file...
Default policy search failed: Could not locate a default source policy or binary
file.

The path should obviously be /etc/selinux/targeted/policy/policy.19, not
/etc/selinux/targeted/policy/policy/policy.19.

The problem is with either libselinux' selinux_binary_policy_path(), or with the
usage of that function in seinfo.
Comment 1 Daniel Walsh 2005-10-04 16:53:40 EDT
Fixed in the upstream version, but am not sure we will put them in U3.
Comment 9 David Lawrence 2006-04-25 14:00:47 EDT
Adding to blocker bug 185483 and adding to IBM group per request of John Jarvis.
Comment 12 David Lawrence 2006-04-27 13:21:52 EDT
Mistakenly added to IBM group, removed.
Comment 13 RHEL Product and Program Management 2006-08-18 13:17:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 18 Red Hat Bugzilla 2007-05-01 19:28:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0192.html

Note You need to log in before you can comment on or make changes to this bug.