Bug 1698573 - wait-for bootstrap-complete and install-complete should be level driven
Summary: wait-for bootstrap-complete and install-complete should be level driven
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.1.0
Assignee: Matthew Staebler
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-10 16:11 UTC by Scott Dodson
Modified: 2019-07-12 05:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:30 UTC

Description Scott Dodson 2019-04-10 16:11:29 UTC
Because events are TTL'd they'll vanish after two hours. If an admin runs `openshift-installer wait-for bootstrap-complete` after that point it won't know whether bootstrap has completed or not and would need to check on a different long lived condition.

Comment 3 Johnny Liu 2019-04-19 07:27:01 UTC
Verified this bug with 4.0.0-0.nightly-2019-04-18-190537, and PASS.

# ./20190419_1/openshift-install version
./20190419_1/openshift-install v4.1.0-201904181302-dirty
built from commit b79562d600f72d0f70aa1514b01e6c07da4dcc8a
release image registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-04-18-190537

# ./20190419_1/openshift-install wait-for bootstrap-complete --dir ./20190419_1/demo1
INFO Waiting up to 30m0s for the Kubernetes API at https://api.qe-jialiu.qe.devcluster.openshift.com:6443... 
INFO API v1.13.4+ff82892 up                       
INFO Waiting up to 30m0s for bootstrapping to complete... 
INFO It is now safe to remove the bootstrap resources 


Reproduced on old version:
After installation is completed, run again the command, the command would be pending there.
# ./20190412/openshift-install version
./20190412/openshift-install v4.1.0-201904101232-dirty
built from commit 741d4db20a2d673eb79cf6dbd076001c9cb65753
release image registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-04-10-182914

# ./20190412/openshift-install wait-for bootstrap-complete --dir 20190419_1/demo1
INFO Waiting up to 30m0s for the Kubernetes API at https://api.qe-jialiu.qe.devcluster.openshift.com:6443... 
INFO API v1.13.4+ff82892 up                       
INFO Waiting up to 30m0s for the bootstrap-complete event... 
^C

Comment 5 errata-xmlrpc 2019-06-04 10:47:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.