Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
.System Purpose settings are now saved when installing RHEL 8 without a network connection
Previously, System Purpose settings were not saved when installing RHEL 8 using the graphical installation without a network connection. As a consequence, the chosen System Purpose settings could not be used by the system during registration. With this update, the System Purpose settings can be used by the system during registration.
Description of problem:
When installing RHEL 8 from binary DVD and setting system purpose attributes, if the system has no network connection, the attributes will not be set after install completes.
The subscription-manager and syspurpose commands also do /not/ work to set them after install if no network is present.
Version-Release number of selected component (if applicable):
subscription-manager-1.23.8-35.el8
python3-syspurpose-1.23.8-35.el8
How reproducible: 100%
Steps to Reproduce:
1. Start installer with Binary DVD/ISO - Ensure network is disconnected
2. Set syspurpose inside anaconda
3. Install and verify syspurpose using 'cat' after done
i.e.: cat /etc/rhsm/syspurpose/syspurpose.json
Actual results:
{} (empty set)
Expected results:
Attributes chosen in anaconda or via syspurpose commands.
Additional info:
If trying to run after install, you will receiver a traceback from subscription-manager commands (for syspurpose), and a name or service not known from syspurpose commands.
Reproducing the failure on RHEL 8.0 machines :
=============================================
on subscription-manager-1.23.8-14.el8
1: installed RHEL80 ISO
2: Set system purpose values
3. Make sure network is disabled on the system.
4.finish installation and check the system purpose values
PFA : 8.0 failure.png to see the failure
Verifying on RHEL8.1 Beta 1.1 compose :
======================================
with the subscription-manager build
# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.25.11-1.el8
1. Installed a RHEL8.1 Beta 1.1 ISO
2. Set system purpose values on the system ( systempurpose.png)
3. Login to system
4. check the system purpose values set and try to configure new values from the network disconnected system
root@localhost ~]# syspurpose show
{
"role": "Red Hat Enterprise Linux Server",
"service_level_agreement": "Standard",
"usage": "Production"
}
[root@localhost ~]# syspurpose set-role "foo"
role set to "foo".
[root@localhost ~]# syspurpose show
{
"role": "foo",
"service_level_agreement": "Standard",
"usage": "Production"
}
[root@localhost ~]# syspurpose set-sla "Premium";syspurpose set-usage "QA"; syspurpose show
service_level_agreement set to "Premium".
usage set to "QA".
{
"role": "foo",
"service_level_agreement": "Premium",
"usage": "QA"
}
Observed that system purpose values set during the installation was intact on the network disconnected system , also successfully modified that system purpose values on the same machine
Based on the above observations , moving the bug to verified.
Additional info:
=============
Demonstrating that the system is a disconnected system
[root@localhost ~]# subscription-manager register
Registering to: subscription.rhsm.redhat.com:443/subscription
Username: QualityAssurance
Password:
Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information.
[root@localhost ~]# syspurpose show
{
"role": "foo",
"service_level_agreement": "Premium",
"usage": "QA"
}
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2019:3561
Comment 19Red Hat Bugzilla
2023-09-14 05:26:50 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days
Description of problem: When installing RHEL 8 from binary DVD and setting system purpose attributes, if the system has no network connection, the attributes will not be set after install completes. The subscription-manager and syspurpose commands also do /not/ work to set them after install if no network is present. Version-Release number of selected component (if applicable): subscription-manager-1.23.8-35.el8 python3-syspurpose-1.23.8-35.el8 How reproducible: 100% Steps to Reproduce: 1. Start installer with Binary DVD/ISO - Ensure network is disconnected 2. Set syspurpose inside anaconda 3. Install and verify syspurpose using 'cat' after done i.e.: cat /etc/rhsm/syspurpose/syspurpose.json Actual results: {} (empty set) Expected results: Attributes chosen in anaconda or via syspurpose commands. Additional info: If trying to run after install, you will receiver a traceback from subscription-manager commands (for syspurpose), and a name or service not known from syspurpose commands.