Bug 1698761 - [Regression][V2V] "Maximum concurrent migrations per conversion host" in UI not working
Summary: [Regression][V2V] "Maximum concurrent migrations per conversion host" in UI n...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.11.0
Assignee: Daniel Berger
QA Contact: Yadnyawalk Tale
Red Hat CloudForms Documentation
URL:
Whiteboard: v2v
Depends On:
Blocks: 1716283 1721118
TreeView+ depends on / blocked
 
Reported: 2019-04-11 08:12 UTC by Yadnyawalk Tale
Modified: 2019-12-13 15:00 UTC (History)
5 users (show)

Fixed In Version: 5.11.0.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1721118 (view as bug list)
Environment:
Last Closed: 2019-12-13 15:00:49 UTC
Category: Bug
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
issue.png (63.81 KB, image/png)
2019-04-11 08:12 UTC, Yadnyawalk Tale
no flags Details
expected_throttling.png (96.25 KB, image/png)
2019-07-29 12:54 UTC, Yadnyawalk Tale
no flags Details

Description Yadnyawalk Tale 2019-04-11 08:12:28 UTC
Created attachment 1554455 [details]
issue.png

Description of problem:
Max per host setting doesn't honor limits from UI


Version-Release number of selected component (if applicable):
5.10.3.1.20190408182335_d0fa1a0 


How reproducible:
100%


Steps to Reproduce:
1. Set max per host number in UI (let say 1 is limit)
2. Run migration (let say 2 migration)


Actual results:
Max per host not working


Expected results:
It should work


Additional info:
We did not had this issue with 5.10.3.0 so I hope it should work on that. We are still checking it.

Comment 5 Yadnyawalk Tale 2019-04-16 16:22:04 UTC
We saw behavior where if we have limit=2, 3 migrations are getting running currently. So if we need to to restrict host limit we can also use upper limit i.e. provider limit.
That means as a workaround by setting host_limit=2 and provider_limit=2 we can run 2 migration and other can get throttled since provider limit is working.

Comment 6 Daniel Berger 2019-04-17 14:12:33 UTC
We've been digging into this but haven't completely nailed it down. Initial investigation suggests a race condition within this block:

https://github.com/ManageIQ/manageiq/blob/master/lib/infra_conversion_throttler.rb#L6-L13

Still digging...

Comment 9 Fabien Dupont 2019-05-16 08:36:07 UTC
We'll need to reproduce once conversion host management works, i.e. on a 5.10.5.x build. If a fix is needed, we'll target 5.10.6.

Comment 11 Daniel Berger 2019-06-13 14:52:54 UTC
In progress: https://github.com/ManageIQ/manageiq/pull/18860

Comment 13 Yadnyawalk Tale 2019-07-29 12:54:43 UTC
Created attachment 1594260 [details]
expected_throttling.png


Note You need to log in before you can comment on or make changes to this bug.