Bug 1698860 - Input amp_hw_arch is missing in Mistral octavia_post_deploy task
Summary: Input amp_hw_arch is missing in Mistral octavia_post_deploy task
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z6
: 13.0 (Queens)
Assignee: Nir Magnezi
QA Contact: Bruna Bonguardo
URL:
Whiteboard:
Depends On:
Blocks: 1581337 1677064 1680494 1689679 1699612 1798064
TreeView+ depends on / blocked
 
Reported: 2019-04-11 11:41 UTC by Itzik Brown
Modified: 2020-02-04 13:59 UTC (History)
15 users (show)

Fixed In Version: openstack-tripleo-common-8.6.8-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1699612 (view as bug list)
Environment:
Last Closed: 2019-04-30 17:28:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1824368 None None None 2019-04-11 14:37:07 UTC
OpenStack gerrit 651788 None MERGED Remove amp_hw_arch from octavia_post 2020-03-31 01:56:33 UTC
Red Hat Product Errata RHBA-2019:0939 None None None 2019-04-30 17:28:16 UTC

Description Itzik Brown 2019-04-11 11:41:28 UTC
Description of problem:
Overcloud deployment fails with the following error:
overcloud.AllNodesDeploySteps.WorkflowTasks_Step5_Execution:
  resource_type: OS::TripleO::WorkflowSteps
  physical_resource_id: 
  status: CREATE_FAILED
  status_reason: |
    resources.WorkflowTasks_Step5_Execution: Failed to run task [error=Invalid input [name=octavia_post_deploy, class=DirectWorkflowSpec, missing=['amp_hw_arch']], wf=tripleo.overcloud.workflow_tasks.step5, task=octavia_post_workflow]:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/mistral/engine/task_handler.py", line 63, in run_task
        task.run()
      File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 158, in wrapper
        result = f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mistral/engine/tasks.py", line 333, in run
        self._run_new()
      File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 158, in wrapper
        result = f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mistral/engine/tasks.py", line 359, in _run_new
        self._schedule_actions()
      File "/usr/lib/python2.7/site-packages/mistral/engine/tasks.py", line 428, in _schedule_actions
        timeout=self._get_timeout()
      File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 158, in wrapper
        result = f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mistral/engine/actions.py", line 576, in schedule
        wf_params
      File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 158, in wrapper
        result = f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mistral/engine/workflow_handler.py", line 54, in start_workflow
        params=params
      File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 158, in wrapper
        result = f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/mistral/engine/workflows.py", line 92, in start
        self.validate_input(input_dict)
      File "/usr/lib/python2.7/site-packages/mistral/engine/workflows.py", line 188, in validate_input
        self.wf_spec.__class__.__name__
      File "/usr/lib/python2.7/site-packages/mistral/engine/utils.py", line 66, in validate_input
        raise exc.InputException(msg % tuple(msg_props))
    InputException: Invalid input [name=octavia_post_deploy, class=DirectWorkflowSpec, missing=['amp_hw_arch']]


Version-Release number of selected component (if applicable):
2019-04-10.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Carlos Goncalves 2019-04-11 12:02:02 UTC
Regression introduced in https://review.openstack.org/#/q/Ia7be6503a40e08d0d1f7f4d89132c9e9b5bd6704

Comment 25 errata-xmlrpc 2019-04-30 17:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0939


Note You need to log in before you can comment on or make changes to this bug.