Bug 16989 - kickstart always tries dhcp
Summary: kickstart always tries dhcp
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-26 18:17 UTC by Michael Redinger
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 23:51:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2000-08-26 18:17:06 UTC
Since RC2 kickstart always seems to send DHCP requests even when DNS is
configured properly in ks.cfg.
On console 3 I see that reverse  lookup works, but then suddenly kickstart
starts searching for a DHCP server, finds it, gets the answer (which says
that there's no configuration for that file), which is displayed on console
4. On console 3 a message is printed that DHCP did not work. As there is
already a working DNS configuration, installation continues (the best sign
is that NFS mount - well, this obviousely means I'm doing a NFS kickstart
insetall - works). However, I don't like our dHCP server being asked by
clients that shouldn't ...
The same config file (just with package list updated) worked fine in RC1.

ks.cfg DNS part:

network --bootproto static --ip 10.0.0.123 --netmask 255.255.255.192
--gateway 10.0.0.190 --nameserver 10.0.0.1
nfs --server myserver.mydomain --dir /my/install/dir

device ethernet 3c59x

Comment 1 Michael Fulbright 2000-08-29 16:22:35 UTC
Brock please try to reproduce.

Comment 2 Brock Organ 2000-11-01 21:20:01 UTC
reassigning these to dale@redhat.com for further review ...

Comment 3 Dale Lovelace 2000-11-08 20:14:12 UTC
I can't reproduce this with 7.0 final. Static networking seems to work without
doing a dhcp call.

Comment 4 Michael Redinger 2001-09-03 10:00:22 UTC
Tried this with 7.2 RC2. Same problem still - although I do specify static parameters, a DHCP lookup is done. As it fails, anaconda falls back to the
provided static information and works fine. 

Can anyone reproduce this?


Comment 5 Matt Wilson 2001-09-06 00:04:47 UTC
I did the following:

network --device eth0 --bootproto static --ip 207.175.44.55 --netmask
255.255.255.0 --gateway 207.175.44.254 --nameserver 207.175.44.1
nfs --server p --dir /mnt/test/msw/i386

and no dhcp request was sent.



Note You need to log in before you can comment on or make changes to this bug.