Bug 1698953 - RPMs openshift-* should be replacing atomic-openshift-* from previous releases
Summary: RPMs openshift-* should be replacing atomic-openshift-* from previous releases
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Luke Meyer
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-11 13:25 UTC by Aleksandar Kostadinov
Modified: 2019-06-04 10:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:30 UTC

Description Aleksandar Kostadinov 2019-04-11 13:25:58 UTC
Description of problem:
There is an error when user tries to install openshift-clients RPM from 4.1 when atomic-openshift-clients 4.0 is already installed. 

Version-Release number of selected component (if applicable):
openshift-clients-4.1.0-201904110044.git.0.ac50

How reproducible:
always

Steps to Reproduce:
1. sudo dnf install openshift-clients

Actual results:
> Error: Transaction check error:
>  file /etc/bash_completion.d/kubectl from install of openshift-clients-4.1.0-201904110044.git.0.ac50235.el7.x86_64 conflicts with file from package atomic-openshift-clients-4.0.0-0.176.0.git.0.1d3f7e4.el7.x86_64
> ...

Expected results:
the old RPM gets replaced

Comment 3 Mike Fiedler 2019-04-30 00:59:30 UTC
This could also be a problem for customer's with the 3.x client installed.  Trying to install openshift-clients with atomic-openshift-clients 3.x installed triggers an error.  It's really more of a nuisance, but a clean upgrade to 4.x would be a good experience.

Comment 5 Luke Meyer 2019-05-03 14:06:19 UTC
In 4.x the openshift build provides openshift-hyperkube which obsoletes atomic-openshift-{hyperkube,node}. I'm going to assume that's not a problem because nobody should be upgrading their nodes this way (but feel free to correct me).

It also creates the openshift-clients RPM which seems to be the only thing at issue here.

Comment 6 Luke Meyer 2019-05-03 14:09:15 UTC
https://github.com/openshift/origin/pull/22764

Comment 9 zhou ying 2019-05-15 02:39:57 UTC
Verified with latest version, the issue has fixed:
Total                                                                                                                                                                              1.1 MB/s |  16 MB     00:14     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                           1/1 
  Installing       : openshift-clients-4.1.0-201905132354.git.0.57d52b2.el7.x86_64                                                                                                                             1/2 
  Obsoleting       : atomic-openshift-clients-3.11.115-1.git.0.419d482.el7.x86_64                                                                                                                              2/2 
  Running scriptlet: atomic-openshift-clients-3.11.115-1.git.0.419d482.el7.x86_64                                                                                                                              2/2 
  Verifying        : openshift-clients-4.1.0-201905132354.git.0.57d52b2.el7.x86_64                                                                                                                             1/2 
  Verifying        : atomic-openshift-clients-3.11.115-1.git.0.419d482.el7.x86_64                                                                                                                              2/2 

Installed:
  openshift-clients.x86_64 4.1.0-201905132354.git.0.57d52b2.el7

Comment 11 errata-xmlrpc 2019-06-04 10:47:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.