Bug 169899 - On saving download, filename is removed from input field after new folder was created
On saving download, filename is removed from input field after new folder was...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 17:10 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 05:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-10-04 17:10:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
In case a new folder was created and changed into during browsing through folders for storing a file, the filename was removed from input field.
Therefore one has to remember the filename or have to repeat from beginning (without creation of folder, because it already exists now)

Version-Release number of selected component (if applicable):
firefox-1.0.7-1.1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Change download settings to ask every time where to store the file
2. Select an URL for downloading
3. Select store to filesystem
4. Browse to folder
5. Create new folder
6. Change into it
7. Save file
  

Actual Results:  Won't work, because filename field is empty after changing into folder

Expected Results:  Ergonimic working...

Additional info:
Comment 1 mobrien 2005-10-09 21:16:15 EDT
This problem exists also in Mozilla.  
Comment 2 Jeff Spirko 2005-12-06 16:28:36 EST
This problem also exists in gedit.
That makes me think it's a GTK2 problem.
Comment 3 Matt Morgan 2005-12-06 16:45:46 EST
It's definitely gnome-wide.

I didn't see this bug when I posted 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=173293

Go there for a workaround that works as long as the parent dir of the new dir is
not otherwise empty.
Comment 4 Peter Bieringer 2006-06-06 05:49:14 EDT
BTW: it's solved in FC5, and I no longer use FC4
Comment 5 Peter Bieringer 2006-06-06 05:52:18 EDT
Ooops, closing bug was not my intention...I do not expect any gnome update for
FC4, so I changed to cantfix.

Note You need to log in before you can comment on or make changes to this bug.