Bug 1699015 - Elasticsearch-operator can get stuck on Pods in 'Pending' phase
Summary: Elasticsearch-operator can get stuck on Pods in 'Pending' phase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Josef Karasek
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-11 14:38 UTC by Josef Karasek
Modified: 2019-06-04 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:30 UTC
Github openshift elasticsearch-operator pull 120 None None None 2019-04-11 14:38:37 UTC

Description Josef Karasek 2019-04-11 14:38:03 UTC
Description of problem:
When the operand gets into 'Pending' phase, the operator cannot progress further.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Deploy EO and some CR
2. Request more resources that the cluster has (e.g. CPU)
3. ES pod gets marked as Unschedulable and its phase is 'Pendig'
4. Correct the CR
5. The operator cannot perform corrective action, the pod is stuck in 'Pending' phase

Actual results:
Pods get stuck


Expected results:
Pods get deployed successfully

Additional info:

Comment 2 Qiaoling Tang 2019-05-05 01:52:55 UTC
Verified on quay.io/openshift/origin-elasticsearch-operator@sha256:d1f9375315fe5544e2e5e748e64a11f4d0983a36fd1bed3f74072772ea65f05b

Comment 4 errata-xmlrpc 2019-06-04 10:47:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.