Bug 1699077 - tripleo-heat-templates generate identical vlan id on compute node on subnet networks and on base network
Summary: tripleo-heat-templates generate identical vlan id on compute node on subnet n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Harald Jensås
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-11 17:19 UTC by Yuri Obshansky
Modified: 2019-09-26 10:49 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190506170359.f08bfef.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
nic-config template (8.72 KB, text/plain)
2019-04-11 17:19 UTC, Yuri Obshansky
no flags Details
network-data.yaml (2.46 KB, text/plain)
2019-04-11 17:21 UTC, Yuri Obshansky
no flags Details
network-environment.yaml (6.59 KB, text/plain)
2019-04-11 17:22 UTC, Yuri Obshansky
no flags Details
network-environment-overrides.yaml (84 bytes, text/plain)
2019-04-11 17:23 UTC, Yuri Obshansky
no flags Details
roles-data.yaml (14.85 KB, text/x-matlab)
2019-04-11 17:23 UTC, Yuri Obshansky
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1821043 0 None None None 2019-04-12 07:30:01 UTC
OpenStack gerrit 645159 0 'None' MERGED Jinja automation for %network%NetworkVlanId 2020-07-08 14:20:05 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:35 UTC

Description Yuri Obshansky 2019-04-11 17:19:44 UTC
Created attachment 1554609 [details]
nic-config template

Description of problem:
Spine Leaf network topology
During Overcloud deployment generated identical vlans on compute nodes placed on subnets and compute node placed on base network.
As result container installation failed
"DEBUG:urllib3.connectionpool:Starting new HTTP connection (1): 172.25.1.246:5000",
        "ERROR:nova_wait_for_placement_service:Retry - Failed to get placement service endpoint:",

Example Base network
[root@overcloud-compute0-0 ~]# ip a |grep vlan
8: vlan1183: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.1.159/24 brd 172.23.1.255 scope global vlan1183
9: vlan1185: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.1.61/24 brd 172.25.1.255 scope global vlan1185
10: vlan1189: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.1.169/24 brd 172.19.1.255 scope global vlan1189

Example Subnet network (leafs)
[heat-admin@overcloud-compute1-0 ~]$ sudo -i
[root@overcloud-compute1-0 ~]# ip a |grep vlan
8: vlan1183: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.2.75/24 brd 172.23.2.255 scope global vlan1183
9: vlan1185: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.2.9/24 brd 172.25.2.255 scope global vlan1185
10: vlan1189: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.2.220/24 brd 172.19.2.255 scope global vlan1189

[root@overcloud-compute2-0 ~]# ip a |grep vlan
8: vlan1183: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.3.70/24 brd 172.23.3.255 scope global vlan1183
9: vlan1185: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.3.85/24 brd 172.25.3.255 scope global vlan1185
10: vlan1189: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.3.72/24 brd 172.19.3.255 scope global vlan1189


Version-Release number of selected component (if applicable):

Compose: RHOS_TRUNK-15.0-RHEL-8-20190403.n.3

openstack-tripleo-common-containers-10.6.1-0.20190404000356.3398bec.el8ost.noarch
python3-tripleoclient-heat-installer-11.3.1-0.20190403170353.73cc438.el8ost.noarch
openstack-tripleo-image-elements-10.3.1-0.20190325204940.253fe88.el8ost.noarch
ansible-tripleo-ipsec-9.0.1-0.20190220162047.f60ad6c.el8ost.noarch
ansible-role-tripleo-modify-image-1.0.1-0.20190402220346.012209a.el8ost.noarch
python3-tripleoclient-11.3.1-0.20190403170353.73cc438.el8ost.noarch
python3-tripleo-common-10.6.1-0.20190404000356.3398bec.el8ost.noarch
openstack-tripleo-validations-10.3.1-0.20190403171315.a4c40f2.el8ost.noarch
openstack-tripleo-common-10.6.1-0.20190404000356.3398bec.el8ost.noarch
openstack-tripleo-puppet-elements-10.2.1-0.20190327211339.0f6cacb.el8ost.noarch
openstack-tripleo-heat-templates-10.4.1-0.20190403221322.0d98720.el8ost.noarch
puppet-tripleo-10.3.1-0.20190403180925.81d7714.el8ost.noarch


How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:
Leaf 1
[root@overcloud-compute1-0 ~]# ip a |grep vlan
7: vlan1179: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.2.4/24 brd 172.19.2.255 scope global vlan1179
8: vlan1173: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.2.15/24 brd 172.23.2.255 scope global vlan1173
9: vlan1175: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.2.8/24 brd 172.25.2.255 scope global vlan1175

Leaf 2
[root@overcloud-compute2-0 ~]# ip a |grep vlan
7: vlan1163: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.3.9/24 brd 172.23.3.255 scope global vlan1163
8: vlan1169: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.3.4/24 brd 172.19.3.255 scope global vlan1169
9: vlan1165: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.3.5/24 brd 172.25.3.255 scope global vlan1165


Additional info:

Comment 1 Yuri Obshansky 2019-04-11 17:21:54 UTC
Created attachment 1554610 [details]
network-data.yaml

Comment 2 Yuri Obshansky 2019-04-11 17:22:56 UTC
Created attachment 1554611 [details]
network-environment.yaml

Comment 3 Yuri Obshansky 2019-04-11 17:23:28 UTC
Created attachment 1554612 [details]
network-environment-overrides.yaml

Comment 4 Yuri Obshansky 2019-04-11 17:23:56 UTC
Created attachment 1554613 [details]
roles-data.yaml

Comment 5 Yuri Obshansky 2019-04-11 17:24:46 UTC
Deployment command
(undercloud) [stack@site-undercloud-0 ~]$ cat overcloud_deploy.sh 
#!/bin/bash
source /home/stack/stackrc

export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates $THT/ \
--timeout 100 \
-e $THT/environments/podman.yaml \
-e $THT/environments/disable-telemetry.yaml \
-e $THT/environments/docker-ha.yaml \
-e $THT/environments/services/neutron-ovn-ha.yaml \
-e $THT/environments/network-isolation.yaml \
-e containers-prepare-parameters.yaml \
-e params.yaml \
-n /home/stack/virt/network/network_data_spine_leaf.yaml \
-r /home/stack/virt/roles/roles_data_spine_leaf.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/network/network-environment-overrides.yaml \
-e /home/stack/virt/nodes_data.yaml \
--log-file overcloud_deployment_90.log

Comment 9 Yuri Obshansky 2019-06-25 15:09:34 UTC
The issue did not reproduce. Verified on compose RHOS_TRUNK-15.0-RHEL-8-20190619.n.1
$ rpm -qa |grep tripleo
puppet-tripleo-10.4.2-0.20190614140424.4ddddb4.el8ost.noarch
openstack-tripleo-common-containers-10.7.1-0.20190614200406.277902e.el8ost.noarch
ansible-tripleo-ipsec-9.1.1-0.20190513190404.ffe104c.el8ost.noarch
python3-tripleo-common-10.7.1-0.20190614200406.277902e.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190611084233.f36d899.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190604170406.2c8a6a5.el8ost.noarch
openstack-tripleo-validations-10.4.1-0.20190617190408.c2b05cf.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190614200406.277902e.el8ost.noarch
openstack-tripleo-puppet-elements-10.3.1-0.20190614132452.79c0c76.el8ost.noarch
openstack-tripleo-heat-templates-10.5.1-0.20190619000409.eff8376.el8ost.noarch
python3-tripleoclient-heat-installer-11.4.1-0.20190611084233.f36d899.el8ost.noarch
ansible-role-tripleo-modify-image-1.0.1-0.20190618030400.8befbdb.el8ost.noarch

VLAN ID generated correctly from provided nic config templates

[root@overcloud-compute1-0 ~]# ip a |grep vlan
8: vlan1179: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.2.197/24 brd 172.19.2.255 scope global vlan1179
9: vlan1175: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.2.135/24 brd 172.25.2.255 scope global vlan1175
10: vlan1173: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.2.153/24 brd 172.23.2.255 scope global vlan1173

[root@overcloud-compute2-0 ~]# ip a |grep vlan
8: vlan1163: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.23.3.175/24 brd 172.23.3.255 scope global vlan1163
9: vlan1169: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.19.3.159/24 brd 172.19.3.255 scope global vlan1169
10: vlan1165: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 172.25.3.121/24 brd 172.25.3.255 scope global vlan1165

Comment 13 errata-xmlrpc 2019-09-21 11:21:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.