Bug 16991 - LPRng -3.6.24
LPRng -3.6.24
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
: FutureFeature
Depends On:
Blocks: 17462
  Show dependency treegraph
 
Reported: 2000-08-26 15:40 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 15:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-08-26 15:40:09 EDT
Since rc2 contains LPRng-3.6.22 and the recently announce 3.6.24 fixes some
bug, I am putting this into bugzilla -- you may have updated already but,
"just in case".

Here is the announcement from the LPRng mailing list:





LPRng: LPRng-3.6.24 available
From: papowell@astart.com
To: lprng@lprng.com
Date: Sat, 19 Aug 2000 14:28:24 -0700 (PDT)


This release solves a couple of problems caused by the addition
of the LPQ status caching.  If you are using LPRng 3.6.22 or
LPRng 3.6.23 please upgrade to this release.

Also added support for parallel port printers,  but it appears
that it is mostly useless unless you use the ifhp filter.

Patrick Powell                 Astart Technologies,
papowell@astart.com            9475 Chesapeake Drive, Suite D,
Network and System             San Diego, CA 92123
  Consulting                   858-874-6543 FAX 858-279-8424 
LPRng - Print Spooler (http://www.astart.com)

Release LPRng 3.6.24 - Fri Aug 11 08:03:23 PDT 2000
 LPRng-HOWTO - added update for Samba print queue configuration.
 LPRng-HOWTO - added section on how to configure Solaris lp printing
  to communicate with LPRng.
  (Changes courtesy of: Gerald Damian <gdamian@ford.com>)
 Typo in gethostinfo.c spotted.
  (Courtesy of the debugging talents of: Robin Sommer
<rsommer@uni-paderborn.de>)
 And I removed the wrong line so that the data files were not being
  deleted when a job was completed.  Helps to read the control file and
  get the data file names...
  (Pointed out by: Thomas Emmel <emmel@mechanik.tu-darmstadt.de>)
 There was a 'cut and pasteo' that caused me to use the wrong value
  to get trim lpq status.
  (Core dump and clues supplied by: John Perkins <john@cs.wisc.edu>)
 LPRng HOWTO - added small section on setting up Solaris lp queues to
  forward jobs to LPRng/BSD printers.
 IPV6 Support fixed up a bit to actually work...
  (Spotted during testing,  now that we actually have IPV6 working
  on our router.)
 Added a 'flush cached status' when a spool server exits.  Now you
  get the correct status when there is no active server.
 Modified the 'Read_write_timeout' code to be consistent with reading
  status from parallel port printers the way that the ifhp filter
  does it.
 Found a minor sillyness in the 'send_to_logger()' code - I carefully
  format data and then toss it way.  Now I do checks first.
 Fixed up lpq status generation - only read a small part of the status
  file for information
Comment 1 Crutcher Dunnavant 2000-10-01 11:12:29 EDT
Upgraded

Note You need to log in before you can comment on or make changes to this bug.