Bug 1699167 - [api-freeze] bump openshift/api for Controller Manager Operator
Summary: [api-freeze] bump openshift/api for Controller Manager Operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Corey Daley
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-12 00:14 UTC by Corey Daley
Modified: 2019-06-04 10:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:40 UTC

Description Corey Daley 2019-04-12 00:14:13 UTC
Per https://github.com/openshift/api/pull/285, the github.com/openshift/api dependency needs to be bumped for the Controller Manager Operator

Comment 1 Corey Daley 2019-04-12 00:15:23 UTC
github.com/openshift/api dependency bump is included in https://github.com/openshift/cluster-openshift-controller-manager-operator/pull/86

Comment 2 wewang 2019-04-12 08:42:50 UTC
@Corey Daley What checkpoint test should we cover for Controller Manager Operator about the bump?

Comment 3 Corey Daley 2019-04-12 17:30:48 UTC
I'm not sure that there is a way to test for that.

Comment 5 Corey Daley 2019-04-18 19:33:30 UTC
The pull request for the api bump has merged.

Comment 7 wewang 2019-04-22 09:17:35 UTC
@Corey Daley  Just confirm with you below 2 part:  I remembered it had the FAILING type before, but now it haven't, is it intended?

$ oc get clusteroperator |grep openshift-controller-manager
                                                                         FAILING     PROGRESSING
openshift-controller-manager         4.1.0-0.nightly-2019-04-22-005054   True        False                   8m25s

And when Updated the OpenShiftControllerManagerOperatorConfigs  to unmanaged, type  Proccessing in clusteroperator is Unknown, not false, right?
$ oc get clusteroperator |grep openshift-controller-manager
                                                                         FAILING     PROGRESSING
openshift-controller-manager                                             Unknown     Unknown                 10s

Comment 8 Corey Daley 2019-04-22 19:59:44 UTC
The operator api is moving towards having a "Degraded" type instead of "Failing", and this operator has already moved to using it.

The unmanaged one is correct, it will be in an unknown state because we are not in charge of it anymore.

Comment 9 wewang 2019-04-23 02:25:50 UTC
Yes, I can see a "Degraded" type, and did a regression test, no issue until now, so verify it. thanks@Corey Daley

Comment 11 errata-xmlrpc 2019-06-04 10:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.