Bug 1699268 - The kibana couldn't be scaled up when replicas=2 in clusterlogging CRD
Summary: The kibana couldn't be scaled up when replicas=2 in clusterlogging CRD
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-12 09:33 UTC by Anping Li
Modified: 2019-06-04 10:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:40 UTC

Description Anping Li 2019-04-12 09:33:31 UTC
Description of problem:
deploy cluster logging when replicas=2 for kibana, the replicas is still 1 in deployment/kibana.


Version-Release number of selected component (if applicable):
 image: quay.io/openshift/origin-cluster-logging-operator:latest
    imageID: quay.io/openshift/origin-cluster-logging-operator@sha256:51f65deb0565f275b1eb34eb510596ef04c3f1c85daffab2b8be1e957f20f218


How reproducible:
Always

Steps to Reproduce:
1. deploy cluster logging using replcias=2 for kibbana
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/logging/clusterlogging/customresource-fluentd.yaml
2. check the replicas number in deployment/kibana
oc get deployment/kibana -o jsonpath={.spec.replicas}

Actual results:


The .spec.replicas=1

Expected results:
The .spec.replicas=2

Comment 1 ewolinet 2019-04-16 15:11:57 UTC
I am able to recreate this. Will investigate further for solution

Comment 4 Qiaoling Tang 2019-04-19 05:13:00 UTC
The .spec.replicas=2 in clusterlogging instance, but only one kibana pod is deployed.
$ oc get clusterlogging -o yaml

    visualization:
      kibana:
        proxy:
          resources: null
        replicas: 2
        resources: null
      type: kibana

    visualization:
      kibanaStatus:
      - deployment: kibana
        pods:
          failed: []
          notReady: []
          ready:
          - kibana-f5db689bd-xccsv
        replicaSets:
        - kibana-f5db689bd
        replicas: 1

CLO image: quay.io/openshift/origin-cluster-logging-operator@sha256:51f65deb0565f275b1eb34eb510596ef04c3f1c85daffab2b8be1e957f20f218

Comment 7 Qiaoling Tang 2019-05-05 01:32:42 UTC
Verified in quay.io/openshift/origin-cluster-logging-operator@sha256:c2988870f4f47617394e6510aca690ddf6ec448b2579c4829e7d34e67e1129ee.

Comment 9 errata-xmlrpc 2019-06-04 10:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.