Bug 16993 - compiling QT fails with __res_state undef...
Summary: compiling QT fails with __res_state undef...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-26 21:36 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 01:05:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-26 21:36:16 UTC
to reproduduce, install pinstripe iso.
download QT source, do ./configure, then make.
It builds the libraries but on the first app
link it says...

g++ -L/grumpy/peter/src/kde_cvs/qt-copy/lib
-Wl,-rpath,/grumpy/peter/src/kde_cvs/qt-copy/lib -L/usr/X11R6/lib
-Wl,-rpath,/usr/X11R6/lib   -o /grumpy/peter/src/kde_cvs/qt-copy/bin/uic
uic.o ../shared/widgetdatabase.o ../shared/domtool.o   -lqutil -L../lib
-lqt -lXext -lX11 -lm   -lSM -lICE -L/usr/X11R6/lib -lGLU -lGL -lXmu
-lresolv
/grumpy/peter/src/kde_cvs/qt-copy/lib/libqt.so: undefined reference to
`__res_state(void)'
collect2: ld returned 1 exit status
make: *** [/grumpy/peter/src/kde_cvs/qt-copy/bin/uic] Error 1
[peter@grumpy uic]$ pwd
/gr

[peter@grumpy qt-copy]$ nm /usr/lib/libresolv.so | grep res_stat
         U __res_state@@GLIBC_2.2
[peter@grumpy qt-copy]$   

Is it a glibc thing?

Comment 1 Need Real Name 2000-08-28 02:21:26 UTC
I entered "pinstripe" as the version, initially, but that got changed into 4.2.
Suspect a problem in bigzilla.

oh... and it's the network/qdns.cpp module implicitly using __res_state.
The #includes look ok (the struct is defined in resolv.h, which looks like
it is included) Why is it saying it's a (void) ?



Comment 2 Jakub Jelinek 2000-09-01 09:29:29 UTC
It was a bug in glibc's resolv.h header, fixed on 2000-08-09.


Note You need to log in before you can comment on or make changes to this bug.