Bug 169938 - RFE: timestamp /tmp/syslog entries
RFE: timestamp /tmp/syslog entries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-10-05 10:12 EDT by James Laska
Modified: 2013-09-02 02:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 15:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-10-05 10:12:19 EDT
# TREE nightly/rawhide-20051005
# ARCH *all*

Was thinking perhaps timestamping /tmp/syslog entries might be useful.  Seems
like it would be a minimal change, that might proof handy in debugging
dhcp/network timeout issues.  We already go about timestamping entries in
/tmp/anaconda.log.  I'm trying to make sense out of doklog() function in
loader2/init.c which looks like it forks and sets up a socket to handle the logging?

Thoughts?
Comment 1 Chris Lumens 2005-10-07 14:41:05 EDT
Yes, doklog handles the logging from the kernel and writes it to /tmp/syslog. 
It would be pretty trivial to add timestamping here as well.  Somewhere on the
giant list of things to do is also to add remote syslogging support to the
loader to match what the second stage is capable of.
Comment 2 Jeremy Katz 2006-01-31 15:32:36 EST
Not going to do this.

Note You need to log in before you can comment on or make changes to this bug.