Bug 1699514 - rubygem-asciidoctor-pdf is not installable
Summary: rubygem-asciidoctor-pdf is not installable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-asciidoctor-pdf
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Sergi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-13 07:48 UTC by Kjell Irgens
Modified: 2019-06-26 15:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 15:32:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Kjell Irgens 2019-04-13 07:48:48 UTC
Description of problem:

rubygem-asciidoctor-pdf 1.5.0-0.7.alpha.16.fc30 seem to have been set up to require older versions of rubygem(prawn-svg) and rubygem(prawn-icon) than what is found in the repositories.

From looking at the upstream gemspec:

https://github.com/asciidoctor/asciidoctor-pdf/blob/master/asciidoctor-pdf.gemspec

s.add_runtime_dependency 'prawn-svg', '~> 0.29.0'
s.add_runtime_dependency 'prawn-icon', '~> 2.3.0'

the Requires statements in the spec file are probably wrong.

Version-Release number of selected component (if applicable):

1.5.0-0.7.alpha.16.fc30

How reproducible:

Always

Steps to Reproduce:
1. dnf install rubygem-asciidoctor-pdf

Actual results:

Last metadata expiration check: 0:37:53 ago on Sat Apr 13 07:06:00 2019.
Error: 
 Problem: conflicting requests
  - nothing provides (rubygem(prawn-svg) >= 0.21.0 with rubygem(prawn-svg) < 0.28.0) needed by rubygem-asciidoctor-pdf-1.5.0-0.7.alpha.16.fc30.noarch
  - nothing provides rubygem(prawn-icon) = 1.3.0 needed by rubygem-asciidoctor-pdf-1.5.0-0.7.alpha.16.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:

Successful installation

Additional info:

Comment 1 Sergi 2019-04-14 09:22:16 UTC
Hey Kjell

thanks for reporting.

Just posted a possible fix for review, will let you know as soon as there's a build to test.

Comment 2 Fedora Update System 2019-04-15 21:10:38 UTC
rubygem-asciidoctor-pdf-1.5.0-0.8.alpha.16.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cc85adb13a

Comment 3 Sergi 2019-04-15 21:14:03 UTC
Kjell, please test the new build and let us know whether it fixes the issue for you.

Thanks.

Comment 4 Fedora Update System 2019-04-16 01:35:51 UTC
rubygem-asciidoctor-pdf-1.5.0-0.8.alpha.16.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cc85adb13a

Comment 5 Kjell Irgens 2019-04-16 12:58:12 UTC
OK, the update has not reached my mirror yet as far as I can see..

Comment 6 Sergi 2019-04-16 17:04:42 UTC
(In reply to Kjell Irgens from comment #5)
> OK, the update has not reached my mirror yet as far as I can see..

Have you checked updates-testing repository as mentioned in comment #4 ?

Comment 7 Kjell Irgens 2019-04-17 09:10:26 UTC
fedora30-x86_64 ~> sudo dnf install asciidoctor-pdf --refresh --enablerepo=updates-testing
Fedora Modular 30 - x86_64                       13 kB/s |  17 kB     00:01    
Fedora Modular 30 - x86_64 - Updates             20 kB/s |  25 kB     00:01    
Fedora Modular 30 - x86_64 - Test Updates        16 kB/s |  21 kB     00:01    
Fedora 30 - x86_64 - Test Updates                24 kB/s |  22 kB     00:00    
Fedora 30 - x86_64 - Updates                     19 kB/s |  24 kB     00:01    
Fedora 30 - x86_64                               27 kB/s |  17 kB     00:00    
Error: 
 Problem: conflicting requests
  - nothing provides (rubygem(prawn-svg) >= 0.29.0 with rubygem(prawn-svg) < 0.30) needed by rubygem-asciidoctor-pdf-1.5.0-0.8.alpha.16.fc30.noarch
  - nothing provides (rubygem(prawn-svg) >= 0.21.0 with rubygem(prawn-svg) < 0.28.0) needed by rubygem-asciidoctor-pdf-1.5.0-0.7.alpha.16.fc30.noarch
  - nothing provides rubygem(prawn-icon) = 1.3.0 needed by rubygem-asciidoctor-pdf-1.5.0-0.7.alpha.16.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)

Comment 8 Kjell Irgens 2019-04-21 06:20:35 UTC
The new version is still not in updates-testing.

Comment 9 Kjell Irgens 2019-04-22 13:16:29 UTC
Sorry, I did not notice that there was a change.  But asciidoctor-pdf is still not installable.  The reason is that the new version requires rubygen-prawn-svg to be newer than 0.29, and the distributed version is 0.28.

Comment 10 Fedora Update System 2019-04-22 17:34:51 UTC
rubygem-asciidoctor-pdf-1.5.0-0.9.alpha.16.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ed742c7f79

Comment 11 Fedora Update System 2019-04-23 14:55:47 UTC
rubygem-asciidoctor-pdf-1.5.0-0.9.alpha.16.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ed742c7f79

Comment 12 Kjell Irgens 2019-04-24 10:08:19 UTC
I can confirm that the RPM can be installed now, and asciidoctor-pdf seem to work from my limited testing.

Comment 13 Sergi 2019-04-25 06:57:11 UTC
(In reply to Kjell Irgens from comment #12)
> I can confirm that the RPM can be installed now, and asciidoctor-pdf seem to
> work from my limited testing.

Thanks for reporting! Could you please provide "karma" at https://bodhi.fedoraproject.org/updates/FEDORA-2019-ed742c7f79 ?

Comment 14 Kjell Irgens 2019-05-09 10:51:49 UTC
I would like to, but I am unable to create a FAS account.

Comment 15 Fedora Update System 2019-05-10 00:47:01 UTC
rubygem-asciidoctor-pdf-1.5.0-0.9.alpha.16.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.