Bug 169961 - Request for openssh-lpk integration with openssh-server
Summary: Request for openssh-lpk integration with openssh-server
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL: http://dev.inversepath.com/trac/opens...
Whiteboard:
Keywords: FutureFeature, Patch
: 204764 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-05 20:38 UTC by Jeff Hardy
Modified: 2008-04-03 14:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:46:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My modified patch, not the official release (58.91 KB, patch)
2005-10-05 20:45 UTC, Jeff Hardy
no flags Details | Diff
Source rpm incorporating lpk (823.68 KB, application/octet-stream)
2005-10-05 20:48 UTC, Jeff Hardy
no flags Details

Description Jeff Hardy 2005-10-05 20:38:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The openssh-lpk patch allows for sshd to read authorized_keys info from an LDAP server, and to do group-based authentication of a user.  I am not one of the developers, but have rolled my own RPMs incorporating the patch to deploy on our site.  Very, very useful.  The patch requires minimal fussing to fit into the current chain of Fedora openssh patches.

Version-Release number of selected component (if applicable):
openssh-server-4.2p1-fc4.1

How reproducible:
Always

Steps to Reproduce:
n/a

Additional info:

I have not done much serious work with RPM packaging, so please let me know what I can improve.  Attached is my source RPM for FC4, and diffs of my spec file and the modified patch file.

Comment 1 Jeff Hardy 2005-10-05 20:45:05 UTC
Created attachment 119651 [details]
My modified patch, not the official release

This patch has been modified to assume it is last in the patch chain as
specified by the .spec file.  The official patch is available at
http://www.opendarwin.org/en/projects/openssh-lpk/files/openssh-lpk-4.1p1-0.3.6.patch

Comment 2 Jeff Hardy 2005-10-05 20:48:22 UTC
Created attachment 119653 [details]
Source rpm incorporating lpk

Comment 3 Tomas Mraz 2005-10-07 08:35:14 UTC
I will consider including this patch in future.


Comment 4 Miloslav Trmač 2007-03-28 10:58:49 UTC
*** Bug 204764 has been marked as a duplicate of this bug. ***

Comment 5 Giuseppe Paterno 2008-04-03 13:56:20 UTC
Any news?
Might be useful for FreeIPA.

Comment 6 Tomas Mraz 2008-04-03 14:46:02 UTC
Unfortunately it was not included upstream yet and we should not increase the
number of non-upstreamed patches in openssh as there are already way too many.



Note You need to log in before you can comment on or make changes to this bug.