Bug 1699726 - Deploy federation v2 controller manager operator failed
Summary: Deploy federation v2 controller manager operator failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-15 05:51 UTC by Qin Ping
Modified: 2019-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:40 UTC

Description Qin Ping 2019-04-15 05:51:59 UTC
Description of problem:
Deploy federation v2 controller manager operator failed

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-04-10-182914   True        False         141m    Cluster version is 4.0.0-0.nightly-2019-04-10-182914

$ oc get sub federation -n federation-system -ojson|jq .spec.startingCSV
"federation.v0.0.8"

How reproducible:
100%

Steps to Reproduce:
1. Login into OCP web console with kubeadmin user
2. Deploy federation v2 operator from catalog->operatorhub
3. Check federation v2 controller manager pod status

Actual results:
$ oc get pod -n federation-system
NAME                                             READY   STATUS             RESTARTS   AGE
federation-controller-manager-6d84b54d6f-7wk2p   0/1     CrashLoopBackOff   6          10m

$ oc get pod federation-controller-manager-6d84b54d6f-7wk2p -n federation-system -ojson|jq .spec.containers[].image
"quay.io/kubernetes-multicluster/federation-v2:v0.0.8"

$ oc logs federation-controller-manager-6d84b54d6f-7wk2p -n federation-system
Error: unknown flag: --install-crds
Usage:
  controller-manager [flags]

Flags:
      --alsologtostderr                         log to standard error as well as files
      --cluster-available-delay duration        Time to wait before reconciling on a healthy cluster. (default 20s)
      --cluster-monitor-period duration         How often to monitor the cluster health (default 40s)
      --cluster-unavailable-delay duration      Time to wait before giving up on an unhealthy cluster. (default 1m0s)
      --feature-gates mapStringBool             A set of key=value pairs that describe feature gates for alpha/experimental features. Options are:
                                                AllAlpha=true|false (ALPHA - default=false)
                                                CrossClusterServiceDiscovery=true|false (ALPHA - default=true)
                                                FederatedIngress=true|false (ALPHA - default=true)
                                                PushReconciler=true|false (ALPHA - default=true)
                                                SchedulerPreferences=true|false (ALPHA - default=true)
      --federation-namespace string             The namespace the federation control plane is deployed in. (default "federation-system")
  -h, --help                                    help for controller-manager
      --kubeconfig string                       Path to a kubeconfig. Only required if out-of-cluster.
      --leader-elect-lease-duration duration    The duration that non-leader candidates will wait after observing a leadership renewal until attempting to acquire leadership of a led but unrenewed leader slot. This is effectively the maximum duration that a leader can be stopped before it is replaced by another candidate. This is only applicable if leader election is enabled. (default 15s)
      --leader-elect-renew-deadline duration    The interval between attempts by the acting master to renew a leadership slot before it stops leading. This must be less than or equal to the lease duration. This is only applicable if leader election is enabled. (default 10s)
      --leader-elect-resource-lock configmaps   The type of resource object that is used for locking during leader election. Supported options are configmaps (default) and `endpoints`. (default "configmaps")
      --leader-elect-retry-period duration      The duration the clients should wait between attempting acquisition and renewal of a leadership. This is only applicable if leader election is enabled. (default 5s)
      --limited-scope                           Whether the federation namespace will be the only target for federation.
      --log-backtrace-at traceLocation          when logging hits line file:N, emit a stack trace (default :0)
      --log-dir string                          If non-empty, write log files in this directory
      --log-flush-frequency duration            Maximum number of seconds between log flushes (default 5s)
      --log_backtrace_at traceLocation          when logging hits line file:N, emit a stack trace (default :0)
      --log_dir string                          If non-empty, write log files in this directory
      --logtostderr                             log to standard error instead of files (default true)
      --master string                           The address of the Kubernetes API server. Overrides any value in kubeconfig. Only required if out-of-cluster.
      --registry-namespace string               The cluster registry namespace. (default "kube-multicluster-public")
      --stderrthreshold severity                logs at or above this threshold go to stderr (default 2)
  -v, --v Level                                 log level for V logs
      --version                                 Prints the Version info of controller-manager
      --vmodule moduleSpec                      comma-separated list of pattern=N settings for file-filtered logging

unknown flag: --install-crds

Expected results:
Federation v2 operator can be installed successfully.


Additional info:

Comment 1 Qin Ping 2019-04-16 02:14:59 UTC
Create a PR for this issue: https://github.com/operator-framework/community-operators/pull/284

Comment 4 Qin Ping 2019-04-23 02:18:58 UTC
Verified with:
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-22-005054   True        False         16h     Cluster version is 4.1.0-0.nightly-2019-04-22-005054

Federation v2 controller-manager version: version.Info{Version:"v0.0.8", GitCommit:"0d12bc3d438b61d9966c79a19f12b01d00d95aae", GitTreeState:"clean", BuildDate:"2019-04-11T04:57:35Z", GoVersion:"go1.11.2", Compiler:"gc", Platform:"linux/amd64"}

Comment 6 errata-xmlrpc 2019-06-04 10:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.