Bug 169977 - Get rid of gtkhtml2 package
Get rid of gtkhtml2 package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtkhtml2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-05 23:22 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 10:01:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-10-05 23:22:02 EDT
Known dependencies: gnucash?
Comment 1 Matthias Clasen 2005-10-05 23:25:37 EDT
no, not gnucash AFAICS, but gnome-python2-gtkhtml2
Comment 2 Matthias Clasen 2006-01-26 08:38:07 EST
and gnome-python2-gtkhtml2 seems to be used by system-config-printer...
Comment 3 Matthias Clasen 2006-01-26 08:45:45 EST
system-config-printer seems to use gtkhtml2 to show foomatic driver/printer notes.
Comment 4 Matthias Clasen 2006-01-26 10:18:15 EST
Tim, does foomatic actually contain  html markup for the driver notes ?
If not, can we just make system-config-printer use a text view, and get rid
of the gtkhtml2 dependency ?
Comment 5 Matthias Clasen 2006-01-26 10:19:19 EST
Another dependency I found is rhn-applet
Comment 6 Tim Waugh 2006-01-26 10:44:56 EST
foomatic does use HTML mark-up, yes.
Comment 7 Christopher Aillon 2006-01-27 15:41:32 EST
Probably too late for FC5 anyway since this would involve swapping dependencies
and stuff.  Moving to FC6Target
Comment 9 Matthias Clasen 2006-07-06 17:47:23 EDT
Add to FC6Destop tracker
Comment 10 Mark McLoughlin 2006-07-13 06:10:20 EDT
anaconda uses it too - see iw/release_notes.py

(Presumably it's not an explicit dep of anaconda because it'll happily fall back
to text mode if gnome-python2-gtkhtml2 isn't installed)
Comment 11 Jeremy Katz 2006-07-13 08:41:31 EDT
Well, we strongly prefer being able to use the HTML release notes (which
requires gtkhtml2) instead of having to do the text ones -- the formatting ends
up being far better and making them lots easier to read.

We switched to gtkhtml2 to get away from having our own HTML parser, so really,
if we're going to get rid of gtkhtml2, we need to have something else to provide
the same functionality (including python bindings).  And gecko isn't practical
for all situations due to the large size
Comment 12 Matthias Clasen 2006-07-19 21:14:32 EDT
Too late for fc6 anyway
Comment 13 Matthew Barnes 2007-01-02 10:01:47 EST
Closing for now since it sounds like dropping gtkhtml2 is not feasible at this
time.  Perhaps we can re-evaluate at a later date, since it would be good to
discard this package.

$ repoquery --alldeps --whatrequires gtkhtml2

gtkhtml2-devel-0:2.11.0-3.i386
gimp-2:2.2.13-1.fc6.i386
gnome-python2-gtkhtml2-0:2.14.2-7.fc7.i386
balsa-0:2.3.14-1.fc7.i386
gphpedit-0:0.9.91-3.fc6.i386
sylpheed-claws-plugins-gtkhtml2-viewer-0:2.6.0-1.fc7.i386
liferea-0:1.2.1-1.fc7.i386
claws-mail-plugins-gtkhtml2-viewer-0:2.6.1-2.fc7.i386
gtkhtml2-0:2.11.0-3.i386

Note You need to log in before you can comment on or make changes to this bug.