Bug 1699801 - APIService v1.quota.openshift.io constantly changes
Summary: APIService v1.quota.openshift.io constantly changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-15 09:21 UTC by Michal Fojtik
Modified: 2019-06-04 10:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:40 UTC

Description Michal Fojtik 2019-04-15 09:21:42 UTC
Description of problem:

The APIService v1.quota.openshift.io constantly changes (every second or so). 

Something always sets the groupPriorityMinimum to 9900 and versionPriority to 15 but couple of milliseconds later something changes it back to 1000/100. And this repeated indefinitely.

This is actually this piece of code https://github.com/openshift/cluster-openshift-apiserver-operator/blob/master/pkg/operator/workloadcontroller/workload_controller_openshiftapiserver_v311_00.go#L332-L351 fighting with this piece of code https://github.com/openshift/origin/blob/master/vendor/k8s.io/kubernetes/pkg/master/controller/crdregistration/crdregistration_controller.go#L216-L224 .

Version-Release number of selected component (if applicable):

4.1

How reproducible:

Always in master.

Additional info:

This was caused by moving the ClusterResourceQuota to CRD. Right now the CRD controller fight with the operator to set the correct priorities.

Comment 1 Michal Fojtik 2019-04-15 11:11:28 UTC
PR: https://github.com/openshift/origin/pull/22573/files

Comment 2 Xingxing Xia 2019-04-19 09:47:47 UTC
Verified in 4.1.0-0.nightly-2019-04-18-210657 :
oc get apiservice v1.quota.openshift.io -o=custom-columns="gpm:.spec.groupPriorityMinimum,vp:.spec.versionPriority" -w # It does not change in the watch.
gpm    vp
9900   15

Comment 4 errata-xmlrpc 2019-06-04 10:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.