Bug 1699808 - Scale up nodes failed due to package "systemd-journal-gateway" not in RHEL or RHEL Extras repo
Summary: Scale up nodes failed due to package "systemd-journal-gateway" not in RHEL or...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.1.0
Assignee: Russell Teague
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-15 09:36 UTC by Weihua Meng
Modified: 2019-06-04 10:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:43 UTC

Description Weihua Meng 2019-04-15 09:36:50 UTC
Description of problem:
Scale up nodes failed due to package "systemd-journal-gateway" not in RHEL or RHEL Extras repo


Version-Release number of the following components:
openshift-ansible-4.1.0-201904091404.git.142.58246b3.el7.noarch

ansible 2.7.9
  config file = /usr/share/ansible/openshift-ansible/ansible.cfg
  configured module search path = ['/home/wmeng/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/local/lib/python3.6/site-packages/ansible
  executable location = /usr/local/bin/ansible
  python version = 3.6.6 (default, Mar 29 2019, 00:03:27) [GCC 4.8.5 20150623 (Red Hat 4.8.5-36)]


How reproducible:
Always 

Steps to Reproduce:
1. config RHEL, RHEL Extras, OCP repos on host to add
$ yum repolist 
Loaded plugins: amazon-id, search-disabled-repos
repo id                                                                                repo name                                                                                                             status
!aos                                                                                   Prerelease OCP                                                                                                           196
oso-rhui-rhel-server-extras                                                            OpenShift Online RHUI Mirror RH Enterprise Linux 7 - Extras                                                            2,139
oso-rhui-rhel-server-releases                                                          OpenShift Online RHUI Mirror RH Enterprise Linux 7                                                                    47,610
repolist: 49,945

2. run scale up ansible playbook
$ ansible-playbook -i ~/hosts playbooks/upgrade.yml


Actual results:

TASK [openshift_node : Install openshift support packages] ********************************************************************************************************************************************************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_node/tasks/install.yml:2
...
    "msg": "No package matching 'systemd-journal-gateway' found available, installed or updated",
    "rc": 126,
    "results": [
        "kernel-3.10.0-957.1.3.el7.x86_64 providing kernel is already installed",
        "3:irqbalance-1.0.7-11.el7.x86_64 providing irqbalance is already installed",
        "2:microcode_ctl-2.1-47.el7.x86_64 providing microcode_ctl is already installed",
        "systemd-219-62.el7_6.2.x86_64 providing systemd is already installed",
        "No package matching 'systemd-journal-gateway' found available, installed or updated"
    ]

Expected results:
ansible playbook finish successfully.

Additional info:
$ yum provides systemd-journal-gateway
Loaded plugins: product-id, search-disabled-repos, subscription-manager
openshift41                                                                                                                                                                                                196/196
systemd-journal-gateway-208-11.el7.x86_64 : Gateway for serving journal events over the network using HTTP
Repo        : rhel7-optional

QE test with RHEL7 optional repo enabled, so this is not testblocker.

Comment 1 Vadim Rutkovsky 2019-04-15 12:11:06 UTC
That seems to be a doc fix - ensure that RHEL Optional repo is enabled, otherwise journald logs from cannot be retrieved by gateway.

I don't think that impairs any functionality except remote log fetching though

Comment 2 Scott Dodson 2019-04-16 12:23:43 UTC
(In reply to Vadim Rutkovsky from comment #1)
> That seems to be a doc fix - ensure that RHEL Optional repo is enabled,
> otherwise journald logs from cannot be retrieved by gateway.
> 
> I don't think that impairs any functionality except remote log fetching
> though

Now that we have installer-gather.sh we intend to remove journal-gatewayd. We should probably drop that package from the install set.
Agree that for now just enable the optional channel to make it past this in testing.

Comment 3 Weihua Meng 2019-04-18 03:28:00 UTC
for now QE will enable optional repo as workaround for test.

keep this bug open as a reminder to track this issue.

Comment 6 Weihua Meng 2019-04-24 02:43:24 UTC
Fixed.

openshift-ansible-4.1.0-201904231432.git.150.9f73bcc.el7.noarch

Comment 8 errata-xmlrpc 2019-06-04 10:47:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.